Welcome to Geeklog Tuesday, September 22 2020 @ 10:59 pm EDT

Geeklog Forums

Login issues after installing phpBBb


Status: offline

garrik

Forum User
Newbie
Registered: 04/12/05
Posts: 2
Using a fresh install of GL 1.3.11sr2 and phpBBb 1.04.

I do not recall having this problem before installing phpBBb.

Once I manage to log into the site, everything works flawlessly. However, I have to go through some jiggling to get on.

Here is my setup:
geeklog 'hidden' section:
/home/geeklog

geeklog public_html:
/home/Public_html/subdir/

phpBB2 directory:
/home/Public_html/subdir/phpBB2

The url for the GL install is:
www.mysite.com/subdir


When I go to the url for the site, it comes up fine. When I log onto the site for the first time on a new system (no cookie for this GL site), I get a 404 error. The url changes from what I entered above to www.mysite.com/subdir/subdir

If I change it back to www.mysite.com/subdir, or hit the 'back' button, it gets into the site and works fine. I can then log into and out of the site, different accounts, etc. and everything seems to work ok.

If I leave an account logged in, then close out the browser, then open the browser again and go back to the site, as soon as I type the url I get a 404 and the url changes to www.mysite.com/subdir/subdir. If I then change it back to www.mysite.com/subdir/subdir, I get another 404. If I change it a third time, it brings up the main page, and again everything seems to work fine.

By 'working fine' I mean that I'm able to browse stories, access the forums (and note that I'm logged in properly there) add stories (when on as an Admin). I have not yet found anything that does not work after manipulating the login as described above.

I was pretty sure based on the symptoms that I had mistyped one of the urls or directory info in a config file somewhere. However, I have checked the GL config.php, the phpBBb config.php, the lib-common.php, and the geeklog.inc files at least 10 or 15 times today. Additionally, it seems odd that if a config gile was borked that the site would function properly once logged in.

I am not certain this is caused by the phpBBb, but that's my best guess at this time.

Can anyone help me?

Thanks!

-Garrik
 Quote

Status: offline

garrik

Forum User
Newbie
Registered: 04/12/05
Posts: 2
Update:

I have confirmed that the geeklog install works fine before installing the bridge. I reinstalled from scratch, and GL worked like a champ.

When I did the install of the bridge, everything worked well until I logged into GL as Admin and ran the install script for phpBBb. When I hit the install button, the script appeared to work, but redirected me back to the /url/subdir/sibdir again and gave me a 404. When I hit the 'back' button, it took me back to the install page. If I clicked on the install button again, it warned that the plugin was already installed. If I reload the page, it shows the plugin as installed.

It appears to me that if I install the bridge to a GL install that is in the /public_html directory, that everything will work properly. The errors I get appear to be caused by my GL installation being in /public_html/subdir.

Any help?

Thanks so much!

-Garrik
 Quote

Mark

Anonymous
I just installed the bridge this morning and noticed the same thing. Every so often it will attempt to open http://mydomain.com/public_html/public_html. Should just be http://mydomain.com/public_html.

If you find the answer please post. I'll keep looking for the aswer as well.

Thanks
Mark
 Quote

Walt

Anonymous
Why use phpBB with GL? Does the GL forum lack that many features? I run a simple website with less than 50 forum users on phpBB and my webhost doesn't support or want us using phpBB anymore, so I'm thinking of migrating to GL's forum system.

Aside from the dancing banana to the side this isn't too all bad is it?
 Quote

All times are EDT. The time is now 10:59 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content