Welcome to Geeklog, Anonymous Monday, April 15 2024 @ 08:38 am EDT

Geeklog Forums

SQL error when posting comments


Richard

Anonymous
Hi, I recently installed Geeklog version 1.3.11sr2 on my site and I'm getting this error message after posting a comment on anything, whether i'm logged in as admin, or as a guest user, or as a test account i made........

An SQL error has occured. Please see error.log for details.

you can see the error yourself by trying to post a comment at RichardsDomain.Com News 'n' Blog

I checked the error.log file and this is the error ....
Wed Nov 30 20:36:49 2005 - 1044: Access denied for user: 'dbusername@IP%' to database 'databasename'. SQL in question: LOCK TABLES gl_comments WRITE

everything else is working fine so far and i've checked and all files and directories are CHMOD as suggested, so i'm lost.

I've only edited the Style Sheet for the 'Proffessional Theme' and also did a timezone hack edit to show my timezone.
Does anyone have any idea of what the problem could be ? is there a setting somewhere within the Admin console, or a line that needs changing somewhere in one of the files?

I haven't installed any addons/plugins and when i try to post a comment it's in plain text mode that i get that error message, i enter comment, then preview it, and when click on 'Submit' is when error page appears.

Thanks in advance Smile i hope to get this working.
 Quote

Status: offline

1000ideen

Forum User
Full Member
Registered: 08/04/03
Posts: 1298
There are various posting on LOCK TABLES e.g. this one: http://www.geeklog.net/forum/viewtopic.php?showtopic=51691
 Quote

Richard

Anonymous
Hiya Smile

Thanks for that. I just checked on another blog and also a cms that i have installed on my site and the Comments work fine on those. So ima take a look at db with phpMyAdmin. It's either something in there or something in Geeklog file somewhere that's stopping it.

Thanks again for putting me onto that link . cheers Smile
 Quote

Status: offline

1000ideen

Forum User
Full Member
Registered: 08/04/03
Posts: 1298
Right,Smile that would help me too because I have the same problem an my hoster is too stupid to answer my emails. So if you find a workaround just post it here, thanks in advance!
 Quote

Richard

Anonymous
I'm lost. I'm new to working with mySQL and phpMyAdmin. So can someone please guide me as to how to do that SQL as mentioned in that link above ? lol ... i need sleep

Thanks in advance, and if i do find a way to fix this, or when someone helps me i'll post when i've atleast got it working.
 Quote

All times are EDT. The time is now 08:38 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content