Welcome to Geeklog, Anonymous Tuesday, November 28 2023 @ 08:26 am EST

Geeklog Forums

Cannot Add/Edit/Delete Stories


I installed GeekLog at the beginning of this year. I went back to it after abondoning the project and I logged in okay. When I go to do anything to the stories (add, edit, or delete), I get this:
Sorry, you do not have access to the story administration page. Please note that all attempts to access unauthorized features are logged

I am logged in as the Admin. All the stories that are posted where made using this log in. I don't know why I cannot add any more, edit, or delete them. I would rather not delete everything and re-install it as I have quite a few members, but I don't know if I have any other choice.


I had a very similar thing happen to me just yesterday. I had freshly installed 1.3.11sr1 on about my 8th site, and everything seemed to be working fine, when suddenly it started giving me an error message when I tried to add or edit any but the original ("Welcome to Geeklog&quotWink story. I had successfully added a new story just minutes before, but then when I tried to edit it I got an (apache, from the look of it) error page which told me I did not have permission to access /admin/story.php. This happened over and over again, no matter what kind of change I tried to make.

It turned out that I could delete the new story, but could not do anything else with it, in either plain text or HTML mode, nor could I add any new stories after that. Oddly enough, I could still edit the original story at will.

I had to go to work at that point, so I did nothing. When I returned home some hours later, everything had apparently returned to normal and I could once again add and edit stories normally. So I wonder: what was the problem?

Status: offline


Forum User
Full Member
Registered: 08/04/03
Posts: 1298
Well, if YOU didn`t chage anything then the next possibility is that your hoster changed something like safe_mode=on or register_globals=off. This happend to me from one day to another. Fortunately in my case Geeklog works with safe_mode=on and the new Geeklog 1.4.0 b1 works even with register_globals=off. so maybe you check with your hoster to give more details here.

All times are EST. The time is now 08:26 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content