Welcome to Geeklog, Anonymous Wednesday, May 22 2024 @ 07:48 pm EDT

Geeklog Forums

rss missing args error


Status: Banned

machinari

Forum User
Full Member
Registered: 03/22/04
Posts: 1512
error tracking skills are lacking today it seems. any help would be appreciated.
this is my error whenever a feed is being created or updated:
Text Formatted Code
Warning: Missing argument 5 for plg_getfeedcontent() in Y:\glCVS\geeklog\system\lib-plugins.php on line 1312

Warning: Missing argument 6 for plg_getfeedcontent() in Y:\glCVS\geeklog\system\lib-plugins.php on line 1312
 

I'm running lib-plugins.php version 1.89. The feed is created/updated, but the errors remain whenever the action takes place. and obviously this is in response to a plugin's feed being updated.
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
What sort of feed is it? Looks like one from a plugin. And which format is it in? The two missing arguments are for the feed format and version number (e.g. "RSS" and "2.0"), which are extracted from the 'format' entry in the gl_syndication table.

My guess: A plugin's feed (Inmemoriam?) where the 'format' entry is still "rss" or similar, as in Geeklog versions prior to 1.4 (in 1.4, it would be "RSS-2.0").

bye, Dirk
 Quote

Status: Banned

machinari

Forum User
Full Member
Registered: 03/22/04
Posts: 1512
yup, now there is my problem... the entries in the table are according to Geeklog 1.4, in fact they were all created using Geeklog 1.4. Each entry in the format column is "RSS-2.0" so I'm left wondering where these are getting lost. The feeds were created using Geeklog 1.4.

and yes, i'm working with an Inmemoriam feed, but I've just tried creating a feed from the Links plugin and the same error occurs. When saving a newly created feed, it flashes the error just before the page refresh if that makes any difference.
 Quote

Status: Banned

machinari

Forum User
Full Member
Registered: 03/22/04
Posts: 1512
My apologies for wasting your time Dirk. I had intermingled a previoius version of lib-syndication with the newest lib-plugins. My bad.

I know I know... Read the FAQ
 Quote

All times are EDT. The time is now 07:48 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content