Welcome to Geeklog, Anonymous Thursday, October 06 2022 @ 02:39 am EDT

Geeklog Forums

comment and article.php redirect to index.php


greg

Anonymous
With geeklog 1.3.11 and php5 (both recently upgraded), I am being redirected to index.php whenever I click on the article link or the comments link. I don't get to view article.php or comments.php. This only recently happened with my upgrade from 1.3.9. Any idea why this is occuring?
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Start here: Geeklog on PHP 5. Also try disabling 'url_rewrite', if you have that set to true.

bye, Dirk
 Quote

greg

Anonymous
I've added a php.ini file to the root directory of the geeklog installation and included the following lines:

register_long_arrays = On

register_globals = On

as the link above says to do. Unfortunantly, that didn't solve my problem... any other ideas?
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Quote by greg: I've added a php.ini file to the root directory of the geeklog installation

That will only work, of course, if your webserver is configured to search for a php.ini there. Is that the case? Usually, the php.ini is located in /usr/local/libs or thereabouts. See Where is my php.ini?

bye, Dirk
 Quote

greg

Anonymous
Thanks for the help again Dirk. I've verified using phpinfo that the php.ini file is located in the correct directory. I changed the file permissions to 755, but that didn't seem to fix it. Is there a statement I can insert into the file to make sure it's being read? And if by chance it is being read by the system, that didn't fix the redirects...

 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Did you restart the webserver? Also check the output of phpinfo() to confirm that register_long_arrays is really on now.

bye, Dirk
 Quote

greg

Anonymous
Yep, register long array's is on: phpinfo. Redirection is still occurring... Anything else that could be causing this?
 Quote

greg

Anonymous
Nevermind... I was able to fix it. I re-read the thread and realized I missed the statement about url_rewrite... once I disabled that it worked fine.

Thanks for the help Dirk!
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
The site seems to work for me. I can read the comments, get the "post a comment" form, ...

What exactly isn't working for you?

Also, you seem to be missing the comment bar on the article pages. Make sure you've updated your theme properly (especially the article/ and comment/ directories). Check with the Professional theme - if things are working there, then it's a theme problem.

bye, Dirk
 Quote

All times are EDT. The time is now 02:39 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content