Welcome to Geeklog, Anonymous Thursday, July 18 2024 @ 08:19 pm EDT

Geeklog Forums

faqman phpbbbridge auth conflict?


Status: offline

scroff

Forum User
Regular Poster
Registered: 02/19/03
Posts: 111
I am running 1.3.12cvs with the phpbb forum 2.0.15. I have just installed Blaine's Faqman. The installation went smoothly but when I try to go to the Faqs, either as admin or as a regular user, I get the following error;

Fatal error: Cannot redeclare auth() (previously declared in /here/home/scroff/scroff.u31.worldispnetwork.com/faqman/data/common.lib.php:217) in /here/home/scroff/scroff.u31.worldispnetwork.com/forum/includes/auth.php on line 51

When I looked at those files they both use function auth(). Is there a way around this?
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Quote by scroff: When I looked at those files they both use function auth(). Is there a way around this?

Obviously, you would have to rename one of them - and in all the places it is being called. I would do it in the FAQ manager, as that is less likely to change anytime soon ...

bye, Dirk
 Quote

Status: offline

Turias

Forum User
Full Member
Registered: 10/20/03
Posts: 807
I even have a FAQ entry about this. Very Happy
 Quote

All times are EDT. The time is now 08:19 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content