Welcome to Geeklog, Anonymous Monday, January 30 2023 @ 09:35 am EST

Geeklog Forums

Geeklog giving error after restore from backup


Ben

Anonymous
I'm getting this when trying to view my site. I had to rebuild the server and put all the files back where they were. Other than the usernames for the virtual sites does include the full domain name now, which it didn't before. So I changed these pathes to match. Basiccly I added the .com to it. Everything else is the same. I'm using Virtualmin module of Webmin to manage the virtual servers.

Warning: main(/home/n9vpu.com/geeklog/config.php): failed to open stream: Permission denied in /home/n9vpu.com/public_html/lib-common.php on line 69

Fatal error: main(): Failed opening required '/home/n9vpu.com/geeklog/config.php' (include_path='.:/usr/share/pear') in /home/n9vpu.com/public_html/lib-common.php on line 69

The files are where they're supposed to be and there is read permition to that folder for everyone, 755. So i don't know where the problem is.

Thanks,
Ben
 Quote

Status: offline

vadertech

Forum User
Full Member
Registered: 05/26/03
Posts: 329
remove the .com and try setting config.php to 777 just to see if either fixes the problem.
GeekLog Hosting, Installations and Upgrades - WWW.AWEHOST.COM - Hosting starts @ only $4.95/mo.
 Quote

Status: offline

bderry71

Forum User
Newbie
Registered: 06/21/05
Posts: 1
Location:Midwestern Illinois
Quote by vadertech: remove the .com and try setting config.php to 777 just to see if either fixes the problem.


Can't as that is the name of the home folder for that domain.

Is this a difect of PHP that it can't handle 2 dots in a path?

Thanks,
Ben
 Quote

Status: offline

vadertech

Forum User
Full Member
Registered: 05/26/03
Posts: 329
i know that 2 dots can trick some paths into thinking that the first dot is the file name instead of a directory. But if this was the case, it should give you a different error message than permissions. Did you try changing the permissions for config.php to 777 to see if that works?
GeekLog Hosting, Installations and Upgrades - WWW.AWEHOST.COM - Hosting starts @ only $4.95/mo.
 Quote

Status: offline

vinny

Site Admin
Admin
Registered: 06/24/02
Posts: 352
Location:Colorado, USA
Are you sure that you have the correct path set up? Make sure your config.php file really is in /home/n9vpu.com/geeklog/. You shouldn't need to chmod config.php as apache only needs read access to that file.

PHP handles having multiple dots (".") in the path with no problem.

-Vinny
 Quote

All times are EST. The time is now 09:35 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content