Welcome to Geeklog Thursday, November 21 2019 @ 11:55 am EST

Geeklog Forums

Enable comments on intro text?


liembo

Anonymous
Is it possible to enable comments on the intro text rather than just the body? The type of blogging I do, I am doing all of the information in the introtext so they need not click to "Read more" so I'd like to have the ability to have people post comments on the introtext right on the page for that particular topic.

Is this possible? Is it a theme issue?
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Yes, it's a theme issue. On most themes, the inital "post a comment" link changes to a link to the article page once a comment has been posted. If you want that link to stay there, use the {post_comment_link} variable in the story templates.

There are other variables that you may want to use - see the documentation (scroll down a bit for the comment variables).

bye, Dirk
 Quote

Liemboi

Anonymous

Perfect. That was what I needed. Thanks.
 Quote

kevin olean

Anonymous
dont mean to keep this redundant thread going as there are a few still out there with the same info...

...however I cannot find where to add {post_comment_link} into. What file and where do I add it?

I would like it to read "Most Recent Post: 05/09 10:04PM by kevinolean Post a Comment [ Views: 48 ]" on each story on the main page.

I know this is going to be right under my nose too... Question
 Quote

Status: offline

kevinolean

Forum User
Newbie
Registered: 10/05/05
Posts: 6
Location:Cheshire, CT
[code] <gavin_> the whole comment bar is missing <tokyoahead> yes <tokyoahead> the layout is damaged <kevinolean> ahhhh <kevinolean> do you know which file it might be? <tokyoahead> nope <gavin_> 1 sec <kevinolean> gavin? <tokyoahead> ah you have the button on the intro-only <tokyoahead> but not when you open the complete article <kevinolean> yeah... <tokyoahead> well I have to go now <gavin_> its in article.thtml <tokyoahead> cul8rs <gavin_> in the article folder <kevinolean> thanks for your help tokyo <tokyoahead> np * tokyoahead has left #geeklog <gavin_> bye tokyohead <kevinolean> ok let me try that <gavin_> open that file and look for {comment_bar} <gavin_> sorry {commentbar} <kevinolean> yeah its there <kevinolean> let me check the comment bar <kevinolean> yeah i dont think i changed anything on there <gavin_> it sure seems weird <kevinolean> yeah tell me about it <gavin_> I am looking for a copy of the clean theme on my computer but can't find one :-/ <kevinolean> i just downloaded geeklog <kevinolean> im getting a clean theme right now... <kevinolean> that did it!!! <gavin_> nice did you just replace that article.thtml file? <kevinolean> no i replaced all the comment files <kevinolean> ill do the article one too <gavin_> can't hurt :-) <kevinolean> hey gavin thanks alot i really appreciate it!!! <kevinolean> ive been kicking myself all night with this! <gavin_> no problem :-) [/code]

Everything is all set now!!! Big thanks to Gavin and Tokyo for helping!!! Big Celebration

Gotta love the IRC channel
 Quote

mbagolden

Anonymous
Had to bump this - seeing that I have the exact same issue. Everything is fine with the intro text, but when I click on "read more" there is no comment bar at the bottom of the article!

I made sure that there was a {commentbar} in article.thtml and that commentbar.thtml was in the comments folder.

Any help would be extremely appreciated!

I am running the current version of GL with the White Pointer theme.
 Quote

mbagolden

Anonymous
I fixed it. Had to upload a new copy of the comments folder.
 Quote

All times are EST. The time is now 11:55 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content