Welcome to Geeklog, Anonymous Friday, September 30 2022 @ 10:11 pm EDT

Geeklog Forums

Template Error?! Please help!


Rosamunda

Anonymous
Hi again!

I´ve got this problem, that´s diriving me nuts...
When I click on any of the stories, it appears this error message:

Text Formatted Code

Template Error: set_root: /home/consorci/public_html/libertador/layout/professional/article is not a directory.
Halted.

 


The link shows as
...../geeklog/article.php?story=20050505172539132

Where´s the problem?

Crying or Very sad Crying or Very sad Crying or Very sad Crying or Very sad Crying or Very sad

Thanks in advance!!!!!!

Rosamunda
 Quote

Rosamunda

Anonymous
I´m sorry, this is the exact link of the error (each article is the same):

http://consorciosonline.org/libertador/article.php?story=20050505172441610
 Quote

Rosamunda

Anonymous
This is how it looks the article.php file:

Text Formatted Code

...
            $story_template->set_var('site_url',$_CONF['site_url']);
            $story_template->set_var('layout_url',$_CONF['layout_url']);
            $story_template->set_var('story_id', $A['sid']);
            $story_template->set_var('story_comments', DB_count($_TABLES['comments'],'sid',$A['sid']));
            $story_template->set_var('lang_comments', $LANG01[3]);
            $articleUrl = COM_buildUrl ($_CONF['site_url']
                                        . '/article.php?story=' . $A['sid']);
            $story_template->set_var ('article_url', $articleUrl);
            $story_template->parse('output','article');
            $display = $story_template->finish($story_template->get_var('output'));
        }
...
 


The thing is that everytime that an article is called (from the index page, from the archive, from the admin area) that error message appears...

Crying or Very sad
 Quote

Rosamunda

Anonymous
BTW... I´ve read the FAQ Read the FAQ

But it didn´t help me:

This is a path problem again. Check the setting for $_CONF['path_html'] in your config.php. If you did not change or rename Geeklog's public_html directory, then there's no need to change that setting at all (restore the line to its original content). Otherwise, please read the comments above that line in config.php again carefully to understand how to change that line properly.

I didn´t change the public_html... I´ve checked the config path and everything seems to be right... In fact I´ve anothe geeklog site inside another folder... and it is working just fine...

Crying or Very sad
 Quote

Status: Banned

machinari

Forum User
Full Member
Registered: 03/22/04
Posts: 1512
did you check to see if the directory referred to in the error message actually exists in where the code is looking for it?

perhaps your professional theme was not expanded properly.
just a guess.
 Quote

Rosamunda

Anonymous
Thanks Machinari! I don´t know what happened, but that were the problem.
I´ve uploaded the theme again and it worked!
Thanks!

Big Celebration
 Quote

All times are EDT. The time is now 10:11 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content