Welcome to Geeklog, Anonymous Friday, August 19 2022 @ 04:58 am EDT

Geeklog Forums

Forum: Edit topic name


Status: offline

ofey

Forum User
Full Member
Registered: 03/18/05
Posts: 213
Location:Dublin, Ireland
thoughtful
Rolling Eyes
In the forum, I'd like to be able to change the topic name, either completely or just to edit a spelling mistake. Is it possible to do this without changing the thread already there?

Regards,

Ofey
Those who say it can't be done, are usually interrupted by others doing it.
 Quote

Status: offline

ofey

Forum User
Full Member
Registered: 03/18/05
Posts: 213
Location:Dublin, Ireland
Anyone?
Perhaps I should post in 'General Help'
Those who say it can't be done, are usually interrupted by others doing it.
 Quote

Status: offline

knuff

Forum User
Full Member
Registered: 12/17/04
Posts: 340
Location:Sweden
Sure, just goto admin > forum and select forums.

You see all the forum topics and description.
Just click edit and save.

The topics are linked to the forum id which is numerical.

Best Regards,
Boris
Vanrillaer.com - our Family Portal
 Quote

Status: offline

ofey

Forum User
Full Member
Registered: 03/18/05
Posts: 213
Location:Dublin, Ireland
Hi Boris,

Sorry for taking so longer to get back. My Geeklog problem just got a whole lot bigger and more serious. A user changed the theme in his 'Preferences' to SmoothBlue from Gameserver. But the site isn't set up for any other themes. I should have disabled this preference for users. I made the same change to the preferences for my own non-admin account. Obviously no problems until I log in and then I get the following error,

Template Error: set_root: /hsphere/local/home/fjryanio/trojanswimclub.ie/layout/Smooth_Blue/forum/layout is not a directory.
Halted.

So this now means I can't change the theme back to 'gameserver'.

I think it's strange that '.../forum/...' is in the path name of the error.

Any ideas,

Shane

PS Your account still exists on this site and has full admin privileges.

I've really gone off the subject here, so I've repeat this post as a
new topic here.
Those who say it can't be done, are usually interrupted by others doing it.
 Quote

Status: offline

ofey

Forum User
Full Member
Registered: 03/18/05
Posts: 213
Location:Dublin, Ireland
hopeful
Hi Knuff,

I followed your instructions,

1. I went to forum in the admin block
http://www.trojanswimclub.ie/admin/plugins/forum/index.php

2. I went to'forums'
http://www.trojanswimclub.ie/admin/plugins/forum/boards.php

3. Then I get a view with my two forums, each of which is divided in 'Forum description'.

4. So then I can either click 'Forum Description' or edit (there are also the options of 'Delete' and 'Resync'.

5. So going to 'Edit' only allows me edit the 'Forum Description'. Clicking on the name of the 'Forum Description' sends me to a list of all the posts within that 'Forum Description'. Here I have only two clickable options.
http://www.trojanswimclub.ie/admin/plugins/forum/messages.php?forum=1&forumname=General

a) Click the name of the person who wrote the post. Clicking this obviously send me to their profile.
b) There's 'Moderate' option beside each 'post'. Clicking this brings me to the thread for that topic. Within that thread I can then 'Delete Post', 'Ban Post' or 'Remove Topic'.

But it seems at no stage can I edit the topics (or name of the thread).

Any Ideas,

Shane

PS I know I took absolutely ages to get back to you. I had an exam, although I was still messing with Geeklog, when I shouldn't have been!
Those who say it can't be done, are usually interrupted by others doing it.
 Quote

Status: offline

jetshack

Forum User
Full Member
Registered: 06/29/04
Posts: 122
Location:Texas
you could just delete the theme smooth blue directory or whichever it is that isn't working and then the next time you log on you'll default back to whatever the default theme is.... that solves your theme issue...

As to your forum issue... I'm not able to recreate it... what version are you using?
 Quote

Status: offline

ofey

Forum User
Full Member
Registered: 03/18/05
Posts: 213
Location:Dublin, Ireland
thoughtful
Hi Jetshack,

Theme issue is solved.

I'm using GL 1.3.11, Gameserver theme and forum version 2.3 Question

It's a small thing really but Knuff says it's possible, then it is.

Shane
Those who say it can't be done, are usually interrupted by others doing it.
 Quote

Status: offline

jetshack

Forum User
Full Member
Registered: 06/29/04
Posts: 122
Location:Texas
Let me preface this with I don't know, but

it almost sounds like you're missing a file... much like the "id already in use" issue when trying to edit a story when using a theme which hasn't been updated for 1.3.10-11

Are there any changes that need to be made to the forum install to acomodate it to the newer versions of gl? Once again I don't know... I'm just asking.
 Quote

Status: offline

ofey

Forum User
Full Member
Registered: 03/18/05
Posts: 213
Location:Dublin, Ireland
Are there any changes that need to be made to the forum install to acomodate it to the newer versions of gl?

I don't know of any.
It's really not a big issue.
Perhaps I should just drop it?
But thanks for your help.

Shane
Those who say it can't be done, are usually interrupted by others doing it.
 Quote

All times are EDT. The time is now 04:58 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content