Welcome to Geeklog, Anonymous Monday, October 03 2022 @ 01:21 pm EDT

Geeklog Forums

Mac OS X Server 10.3 and Apache REMOTE_ADDR


Status: offline

pjbeyer

Forum User
Newbie
Registered: 04/08/05
Posts: 2

i've just corrected a problem with my new Geeklog install. it seems that references to the Apache environment variable 'REMOTE_ADDR' return the OS X server ip address instead of the remote client's. this is a problem because it breaks polls, comment speed limits apply across the entire site, etc.

as a working solution, i have replaced all references to REMOTE_ADDR with HTTP_PC_REMOTE_ADDR. i'm unclear as to whether this is a Mac OS X 10.3 specific issue, an Apache issue, a Geeklog issue, or what. i'm really just posting this to document what i did and get some feedback. maybe my server is misconfigured or something?

i also disabled the 'Performance Cache' option on my Geeklog site. does anyone have experience with using that option successfully or not?
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Never heard of that one before and it's certainly not a Geeklog issue.

bye, Dirk
 Quote

Status: offline

pjbeyer

Forum User
Newbie
Registered: 04/08/05
Posts: 2

i've assumed it was either a OS X Apache issue or an issue with the specific setup of my server (which is fairly vanilla at this point)... if i gather any more information about it, i'll be sure to share
 Quote

Feng-Shui

Anonymous
Yeah i've just run into this problem too, have done the search/replace, but that seems to have killed my $_COOKIE['geeklog'] cookie, and i need that cookie for some custom stuff i've written Banging your head
 Quote

Feng-Shui

Anonymous
Hmmm, after taking a further look into the code i am wondering has anyone else fixed this problem while retaining the geeklog cookie (the cookie that holds the uid)? I don't want to go messing around in the code too much if someone else has solved this problem. I'm running server 10.4.4 apache 1.3.
Also, anyone know what the geeklog cookie is used for?
Cheers.
 Quote

Status: offline

rasher

Forum User
Newbie
Registered: 03/21/04
Posts: 12
It sounds like an issue I had years back.
By default OS X server enables performance cache for each website. So PHP apps think everyone is coming from the servers IP address using a port somewhere in the 16,000 range.

I haven't had to disable it since version 10.2 but it should be similar. Just open your Server Settings application (or whatever it's called these days). For each website, go into the edit screen and under the Options tab...
Uncheck the option "Enable performance cache". Do that for each website, if you are running more than one website.

That worked for me in a similar PHP application install however it wasn't Geeklog.

It would be interesting to hear if this helps for your situation, for future reference.

Good luck,
Randy
 Quote

Feng-Shui

Anonymous
Even with the cache option off it still doesn't help. I had already diabled it as it was wreaking havock when editing pages and having to refresh 5 or 6 times before a change took effect.
Cheers,
Chris
 Quote

All times are EDT. The time is now 01:21 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content