Welcome to Geeklog Wednesday, December 11 2019 @ 01:54 pm EST

Geeklog Forums

Changing IP address


Tristan

Anonymous
Ive been ask to get access to a linux mandrake machine and change its IP address - then told it has an intranet and its really useful.

Turns out to be Geeklog 1.3 - i havent heard of it before, looks interesting.

Ive changed the IP address in -
/etc/sysconfig/network-scripts/ifcfg-eth0
/etc/hosts
thru your help pages i also found an entry in /var/www/html/geeklog/config.php pointing to the old address -
$_CONF['site_url'] = 'http://10.1.2.4';
have changed this to reflect the new address of 192.168.5.99

the system is running Apache 2.0, i expected to find an entry under virtual hosts with the ip details, to me it looks like its wrapped up in php - php is beyond me.

When i try to connect to the newly addressed system 'http://192.168.5.99' it changes the ip address back to the original address 'http://10.1.2.4/index.php' then reports 'the page cannot be displayed'
Any help in pointing me in the right direction would be greatly appreciated.
Thanks

Tristan
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
$_CONF['site_url'] ist the variable that defines the URL of the Geeklog site. All other URLs are derived from that value.

In other words: The problem must lie somewhere else, outside of Geeklog.

bye, Dirk
 Quote

Status: offline

newblogger

Forum User
Regular Poster
Registered: 22/08/04
Posts: 107
Location:Virginia Beach
did you check your dns configuration?
Got Hot wheels? http://www.dcmotoring.com
 Quote

Status: offline

beewee

Forum User
Full Member
Registered: 05/08/03
Posts: 969
Location:The Netherlands, where else?
You have to set the correct path to config.php in /public_html/lib-common.php as well, but I doubt if that's what you're looking for.
Dutch Geeklog sites about camping/hiking: www.kampeerzaken.nl | www.campersite.nl | www.caravans.nl | www.caravans.net
 Quote

tokyoahead

Anonymous
check the server name and alias settings in the apache httpd.conf

they should match the new IP.
 Quote

All times are EST. The time is now 01:54 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content