Welcome to Geeklog Wednesday, September 23 2020 @ 06:37 am EDT

Geeklog Forums

Staticpages error - URL Class


Status: offline

Steven

Forum User
Newbie
Registered: 13/10/04
Posts: 10
Just upgraded from 1.3.9 to 1.3.11.

During upgrade, I forgot to update lib-custom with path-to-geeklog. After doing the DB upgrade, the next page failed to draw, I got a path error. I corrected lib-custom and tried install.php again. This time I got a duplicate column error message. So I have no idea if the upgrade went through or not. My site is up and everything seems to work and then I tried to edit a static page and save it. That's when I got:

URL Class: number of names passed to setArgNames must be equal or greater than number of arguments found in URL

Could this be because the DB didn't get completely updated due to the lib-custom issue?


Update: I dump my database and reloaded it with the DB from 1.3.9. I then re-ran the install and it completed without errors. I still get the error message above.


Mechwars Robot Combat Webmaster www.tcmechwars.com Fight Robots Not People
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Do you have $_CONF['url_rewrite'] = true? Try setting it to false.

Which PHP version are you on?

bye, Dirk
 Quote

Status: offline

Steven

Forum User
Newbie
Registered: 13/10/04
Posts: 10
I had it on. I turned it off and tested - now it works.

PHP Version 4.3.8

Thanks.

Mechwars Robot Combat Webmaster www.tcmechwars.com Fight Robots Not People
 Quote

All times are EDT. The time is now 06:37 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content