Welcome to Geeklog, Anonymous Tuesday, January 31 2023 @ 09:05 pm EST

Geeklog Forums

installation problem.. i'm going crazy


Luc@ Web

Anonymous
Please help me, i've tried so much configuration but i still have problem...

Fatal error: Cannot instantiate non-existent class: database in D:Inetpubwebspulsarelationcomsystemlib-database.php on line 117

My config:

$_DB_host = 'my ip; // host name or IP address of your DB server
$_DB_name = 'my database'; // name of your database,
// must exist before running the installer!
$_DB_user = 'my login'; // MySQL user name
$_DB_pass = 'my password'; // MySQL password

// The table prefix is prepended to each table used by Geeklog to avoid name
// collisions with other tables that may already exist in your database.
$_DB_table_prefix = 'gl_'; // e.g. 'gl_'


// +---------------------------------------------------------------------------+
// | (2) Paths |
// +---------------------------------------------------------------------------+

// Note for Windows users: It's safe to use the forward slash '/' instead of
// the backslash '' in paths. Make sure each path starts with a drive letter!

// This should point to the directory where your config.php file resides.
$_CONF['path'] = 'http://www.pulsarelation.com/'; // should end in a slash

// You only need to change this if you moved or renamed the public_html
// directory. In that case, you should specify the complete path to the
// directory (i.e. without the $_CONF['path']) like this:
// $_CONF['path_html'] = '/path/to/your/public_html/';
$_CONF['path_html'] = $_CONF['path'] . 'glog/';


// +---------------------------------------------------------------------------+
// | (3) Site Settings |
// +---------------------------------------------------------------------------+

// Make sure this is the correct URL to your site, i.e. to where Geeklog's
// index.php file resides (no trailing slash).
$_CONF['site_url'] = 'http://www.pulsarelation.com';

// Some hosting services have a preconfigured admin directory. In that case,
// you need to rename Geeklog's admin directory to something like "myadmin"
// and change the following URL as well. Leave as is until you experience any
// problems accessing Geeklog's admin menu.
$_CONF['site_admin_url'] = $_CONF['site_url'] . '/glog/admin';

if i put the path without "http://...."

Warning: main(/system/databases/mysql.class.php): failed to open stream: No such file or directory in D:Inetpubwebspulsarelationcomsystemlib-database.php on line 114

Fatal error: main(): Failed opening required '/system/databases/mysql.class.php' (include_path='.;c:phpincludes') in D:Inetpubwebspulsarelationcomsystemlib-database.php on line 114


please help me.

Thanks
 Quote

Status: offline

tstockma

Forum User
Full Member
Registered: 07/22/03
Posts: 169
I probably won't be much help, not a database guy & my install as far as the database went well.

I'm looking at the 4 lines of DB config info in your post, I'm assuming you nuked your actual values from the text of your post...on _DB_host, it looks like you had entered the IP.

If this is on the same server as your web site is, try "localhost".

Luck!
Tom
www.southparkcity.com
 Quote

All times are EST. The time is now 09:05 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content