Welcome to Geeklog Sunday, July 21 2019 @ 07:06 pm EDT

Geeklog Forums

phpBBbridge and users being logged in


Status: offline

penguin

Forum User
Newbie
Registered: 01/12/04
Posts: 11
I am running geeklog 1.3.11 and the phpBBbridge 0.77.

The problem is that for some users geeklog will show them as beign logged in. The username will be displayed in the phpBB users online list. But when they go to post phpBB says they need to login. If they then re-login they are ok until the next visit.

Is this a known bug with phpBBbridge? Is there a fix?

Thanks

Status: offline

Turias

Forum User
Full Member
Registered: 20/10/03
Posts: 807
Well, it was an issue before. But, I thought I had fixed it.

I have been using 0.77 for a while, and I have yet to see this happen with that version. First, make sure that your users completely clear their cookies. Then, if it still happens, I'll be able to look at it if you can get me a step-by-step way to reproduce it.

Status: offline

penguin

Forum User
Newbie
Registered: 01/12/04
Posts: 11
I found a method that seems to cause this issue on a steady basis.

If a user is using the subsilver that was included with the bridge and they click on a link from another site to my forums they are not logged in. If they are using the alternative skin I have then they stay logged in.

Status: offline

Turias

Forum User
Full Member
Registered: 20/10/03
Posts: 807
The themes shouldn't have any effect on logging in. Hmmm... I'll see if I can reproduce it.

Status: offline

Turias

Forum User
Full Member
Registered: 20/10/03
Posts: 807
Well, I can't see anywhere where different themes would affect your ability to login. Does anything get written to your error.log?

Status: offline

andyofne

Forum User
Chatty
Registered: 31/08/02
Posts: 69
I've had that problem with a straight PHPBB site (no geek intergration involved)... users that clicked on links to topics or forum posts from outside the forum (ICQ, MSN, e-mail, or other sites) would often be required to log in despite already being logged in.

We never figured out what the fix was for that problem.

Status: offline

Turias

Forum User
Full Member
Registered: 20/10/03
Posts: 807
Hmmm, that sounds possible, especially if there is a session ID variable in the link.

Thanks, andyofne.

All times are EDT. The time is now 07:06 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content