Welcome to Geeklog Friday, May 07 2021 @ 04:22 am EDT

Geeklog Forums

Gallery / Geeklog Intergration


Status: offline

jennamatic

Forum User
Newbie
Registered: 13/11/04
Posts: 4
I'm trying to intergrate Gallery v1.4.1 into Geeklog 1.3.9sr1.

I installed Gallery and configured with the option to intergrate into geeklog. This appears to have been successful as I am able to view the gallery directory without errors, edit albums, retain admin rights when i go from geeklog to gallery, exc.

My problem is the gallery doesn't display the geeklog interface (site header and blocks) around it. It doesn't even use the geeklog stylesheets, so the gallery page shows up without any colors or fonts. The gallery is displaying my geeklog footer info.

My geeklog does not have any links or admin options for gallery. I am wondering how to get my gallery to wrap into my geeklog interface..(meaning display the header, blocks, and stylesheet) and how to have my geeklog recognize (or link into) my gallery.

THANKS!
 Quote

Status: offline

g3cko

Forum User
Newbie
Registered: 21/10/03
Posts: 13
Quote by jennamatic: I'm trying to intergrate Gallery v1.4.1 into Geeklog 1.3.9sr1.


maybe i'm wrong here.. but why install a really old release of gallery that needs patching just to work with geeklog, when the newer version (1.4.4-pl4 for sure) works out of the box with geeklog (and fixes important security issues)
 Quote

Status: offline

jennamatic

Forum User
Newbie
Registered: 13/11/04
Posts: 4
Yeah that doesn't make much sense -- I would love to install the newest version -- especially if it just works. But that's whats strange --

I downloaded v1.4.4.... it has the options in config to automaticly intergrate with geeklog... so it would have to be 1.4.4 right? Anyhow, I did install that new version ... but for whatever reason my gallery screen shows it as v1.4.1. It had the geeklog intergration functions though, which are partially working. Its just the iface intergration that's causing the problem.
 Quote

Status: offline

g3cko

Forum User
Newbie
Registered: 21/10/03
Posts: 13
umm... its been a little while since i setup it up, but my guess would be that maybe the path to your geeklog dir isn't set? or is set incorrectly?

it doesn't integrated into geeklog admin section, but if you go into the gallery admin section you can set permissions based on geeklog users/groups
 Quote

Status: offline

jennamatic

Forum User
Newbie
Registered: 13/11/04
Posts: 4
well geeklog is installed on my root dir... so i set the config option to /
it would seem that worked correctly based on the fact that my gallery reads my geeklog footer, but i just dont understand why it doesn't reference the geeklog stylesheet.

as for gallery adding admin features to gl... i had wondered if it would. how do you have your gallery linked to your geeklog at all? right now i have to manually type in the /gallery when in GL to go there. so far the only way i've figured to link the two would be with a menu plug in or something. is that the only option though?

i just wish i could figure out how to get geeklog to wrap around my gallery!

Thank you

Oh yeah, and I can see the album editing options on the main gallery page when I'm logged in, but I can't figure out how to get to any other admin section. Could you help me with that?
 Quote

Status: offline

vinny

Site Admin
Admin
Registered: 24/06/02
Posts: 352
Location:Colorado, USA
Quote by jennamatic: well geeklog is installed on my root dir... so i set the config option to /

Well if it seems to be working, we won't worry about that. Smile

Quote by jennamatic:it would seem that worked correctly based on the fact that my gallery reads my geeklog footer, but i just dont understand why it doesn't reference the geeklog stylesheet.

Are you using a relative path to access the style sheet? If so, that is likely the problem.

Quote by jennamatic:as for gallery adding admin features to gl... i had wondered if it would. how do you have your gallery linked to your geeklog at all? right now i have to manually type in the /gallery when in GL to go there. so far the only way i've figured to link the two would be with a menu plug in or something. is that the only option though?

Edit your template files. Most likely you want to edit header.thtml (by adding a link to your gallery).

Quote by jennamatic:i just wish i could figure out how to get geeklog to wrap around my gallery!

Patience, we'll get you there.

Quote by jennamatic:Thank you

Your welcome

Quote by jennamatic:Oh yeah, and I can see the album editing options on the main gallery page when I'm logged in, but I can't figure out how to get to any other admin section. Could you help me with that?

The links to admin control are sprinkled over Gallery, most of them are accessible from within an album.

If you send us the URL to your site we'll be able to help you much more easily and we'll have a better understanding of the problems your having.

-Vinny
 Quote

All times are EDT. The time is now 04:22 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content