Welcome to Geeklog Saturday, May 21 2022 @ 12:42 pm EDT

Geeklog Forums

Geekary Problem


Status: offline

ojm

Forum User
Newbie
Registered: 28/09/04
Posts: 1
I'm having some trouble with Geekary image gallery.

The error goes as following when I try and upload an image:

"The Album you tried to upload to does not accept the type of file you sent."

Well, I don't understant, its a jpg file which I have marked as accepted and the directroy where the files are uploaded is correctly chmod'ed, so I'm stuck.

Any suggestions would be appreciated.
 Quote

Status: offline

4Xsample

Forum User
Junior
Registered: 21/09/03
Posts: 26
I have the same problem Sad
you could fix it¿?
I have installed Geeklog 1.3.10. and geekary 1.0 with another problem with the sending mail system but I think it cant affect
 Quote

Status: offline

Benta

Forum User
Regular Poster
Registered: 11/03/05
Posts: 80
Quote by ojm: I'm having some trouble with Geekary image gallery.

The error goes as following when I try and upload an image:

"The Album you tried to upload to does not accept the type of file you sent."

Well, I don't understant, its a jpg file which I have marked as accepted and the directroy where the files are uploaded is correctly chmod'ed, so I'm stuck.

Any suggestions would be appreciated. Banging your head Can someone help me


some cameras do not save proper jpgs. for instance, my cameraphone has images that gdlib can't handle

if this is the problem, just convert them to proper jpgd with a program that can open them (ms paint handles most of them, actually)
 Quote

Status: offline

4Xsample

Forum User
Junior
Registered: 21/09/03
Posts: 26
for the moment I could "fix it" but in a shit way, I commented in the config.php from the geekary the part where is defined the control of the filetype so now I can load images but I dont like that way.

in the other side I cant autogenerate Thumbnails and I dont know why it dont apear the edit image buton
 Quote

Status: offline

Benta

Forum User
Regular Poster
Registered: 11/03/05
Posts: 80
Quote by 4Xsample:
in the other side I cant autogenerate Thumbnails


well, that REALLY sounds like the problem I talked about with "bad" jpgs. where did you get the pictures from?
 Quote

Status: offline

4Xsample

Forum User
Junior
Registered: 21/09/03
Posts: 26
I try a wide kind of images, png, jpg, gif, bmp, from diferent sources some from smartphones, some from digital cameras some from scanner and some from the web and all of them in the original format and modified with the photoshop for overwrite the posible format mistakes

actually theres only one photo directly taken from the smartphone and the website is on www.4Xsample.com/anidra/
 Quote

Status: offline

Chalkhillian

Forum User
Chatty
Registered: 23/09/02
Posts: 67
Quote by 4Xsample: I have the same problem Sad
you could fix it¿?
I have installed Geeklog 1.3.10. and geekary 1.0 with another problem with the sending mail system but I think it cant affect


Hmmmm - I'm running GEEKARY V1.3 - Is there a reason that you're not running the latest version?

If you can't get thumbnails to work, which are you configured for - ImageMajick , NetPBM or GD Lib ?
 Quote

Status: offline

4Xsample

Forum User
Junior
Registered: 21/09/03
Posts: 26
I have all the pacages installed and I tried with all of them
 Quote

Status: offline

1000ideen

Forum User
Full Member
Registered: 04/08/03
Posts: 1298
This is really a silly error: "The Album you tried to upload to does not accept the type of file you sent." The cause is that the category has to be set too.

Once you adjust the main settinges and once more you have to adjust the category settings! Unfortunately the boxes there are unchecked by default.

Another error is that when you don´t permit ratings and you delete some pictures you will get this error:

Fatal error: Call to undefined function: ratings_clearratings() in /srv/www/htdocs/web111/files/geeklog_conf/plugins/geekary/display.inc on line 228

Well, on the other hand it is a nice gallery and maybe somone comes along and improves it a little.
 Quote

Status: offline

ch4rm

Forum User
Newbie
Registered: 20/04/05
Posts: 5
I'm getting the same problem he's been having, except with ALL jpg files. Everything is checked in permissions both in Geekary settings and the album settings. I didn't find the part in the config.php where it talked about which filetype to accept for me to comment out though, any ideas on how to fix this? thanks.
 Quote

Status: offline

1000ideen

Forum User
Full Member
Registered: 04/08/03
Posts: 1298
I haven`t found anything in the config either. It may be important to enable everything too as some settings like "non rating" of pictures led to unexpected problems.

The files are not too big? Other types work?
I think the best gallery is: http://gallery.menalto.com/modules.php?op=modload&name=News&file=index
 Quote

Status: offline

ch4rm

Forum User
Newbie
Registered: 20/04/05
Posts: 5
yes, all other types work fine, and the file sizes of these jpg's are only 33k, so there shouldn't be problem there.
 Quote

All times are EDT. The time is now 12:42 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content