Welcome to Geeklog, Anonymous Friday, December 09 2022 @ 11:56 am EST

Geeklog Forums

Login fails on OSX, works on Windows

Page navigation


Status: offline

danv

Forum User
Junior
Registered: 08/30/04
Posts: 22
Quote by macboy: the fix is to simply turn off Rendezvous on the server, OR, disable apache from using it.


aaah - but this webserver is runing Webstar instead of Apache... (see above a bit...)

So I'll look up how to disable Rendezvous on the server - or do you have a quick link you can email me?

Thanks a ton, macboy! I really appreciate your help.

Dan
 Quote

Status: offline

macboy

Forum User
Junior
Registered: 06/10/04
Posts: 15
Then I'm not sure how 4D Webstar knows to advertise itself via Rendezvous. Look for this file WSWebServer.prefs.xml or use the Webstar Admin Client and see if there's anything in there to disable Rendezvous advertising of HTTP. If that doesn't work, I'll tell you how to stop Rendezvous from running entirely.
 Quote

danv

Anonymous
Can't find anything in the webstar config to disable Rendezvous.

Found this on the Apple website to disable Rend. for server: http://docs.info.apple.com/article.html?artnum=151464

Is that the right thing to disable?

Thx, Dan
 Quote

Status: offline

danv

Forum User
Junior
Registered: 08/30/04
Posts: 22
OK - I disabled Rendezvous in the directory access GUI, and I still can't login with OSX clients... unless I configure "site_url" as machinename.local - but then OS9 clients can't login.

Any other ideas before going the internal DNS route?

thanks again,
Dan
 Quote

Status: offline

macboy

Forum User
Junior
Registered: 06/10/04
Posts: 15
That article does not disable Rendezvous. It just stops the server from discovering certain things, not from offering them. I have to go off-site for the rest of the afternoon. I'll post the removal details for you tonite.
 Quote

Status: offline

danv

Forum User
Junior
Registered: 08/30/04
Posts: 22
Will this do it? (Copied from this site...)

If you want to prevent Rendezvous from running on the system, move
/System/Library/StartupItems/mDNSResponder directory to a backup location and restart the system. Just don't muck around with settings that depend on it, like the Rendezvous plug-in in Directory Access after removing the startup item.
 Quote

Status: offline

macboy

Forum User
Junior
Registered: 06/10/04
Posts: 15
That's exactly what I was going to tell you. In addition, document that you've done it. I have come across a software package or 2 that assumes the mDNSresponder is running if the host is >=10.2... this has wreaked havoc on one commercial package that I deployed...

****CYA disclaimer***
In order to do this, you must be root, or use sudo from the command line. Backup before doing this, ect.... Here we go!!

sudo mv /System/Library/StartupItems/mDNSResponder ~/Desktop

That will move the file to your desktop (basically, we're not deleting it, just moving it out of the way). Now reboot the machine. ***NOTE we've just broken ALL SERVICES THAT RELY ON Rendezvous on this box. That means no iTunes music sharing, no local iChat using Rendezvous, no Rendezvous file-shares or printers.... You get the point.

If you need to roll this back, simply issue this command:
sudo mv ~/Desktop/mDNSResponder /System/Library/StartupItems/

...and then reboot. All will be well again.


Let me know how this works!!!! If it doesn't, you'll have to run Geeklog in the built-in Apache, and disable mod_rendezvous.
 Quote

Status: offline

rjrufo

Forum User
Regular Poster
Registered: 06/14/03
Posts: 95
After disabling Rendezvous, you can set up Apache 2.0.48 by using the downloadable package, Complete Apache 2, from Server Logistics. While you're at it, why not install Complete MySQL as well? I've found them much easier to use than going into Terminal and using the command line. They also have Preference Panes so you can control them from the System Preferences window.
 Quote

Status: offline

danv

Forum User
Junior
Registered: 08/30/04
Posts: 22
Well, I did the directory move & reboot as listed above, and it worked, and it didn't...

Now, I can login with OSX clients using Mozilla, Netscape, or IE - but I cannot login using Safari.

This IS an improvement - before OSX clients could not login - regardless of browser. However, they REALLY want to use Safari - so does anyone have any tips?

I've already cleared the cache, deleted cookies, power refreshed, multiple times... no dice. I don't get the cookie at all with Safari, hence can't login...
 Quote

Status: offline

macboy

Forum User
Junior
Registered: 06/10/04
Posts: 15
Good Job! Glad to hear that it worked (sort-of). What version of Safari, and what OS (10.2 or 10.3)??
You will not be able to use machine-name.local with Safari (if that's what you're trying). You may also have to change you cookie name and the site_url again. Make sure you're not using xxxxx.local anywhere in the config.php file, because Safari will attempt to resolve, and fail (other browsers are not Rendezvous enabled, so they work just fine).

1: Are you using the IP when attempting to connect with Safari?

2: Will Safari even bring up the main page and let you see the login?

I'm guessing that you see the page, and when you click to login, the page refreshes and looks like nothing happened. Is that correct?? If so, my guess is to check your config.php file and make sure you've removed all occurences of xxxx.local.

Let me know!
 Quote

Status: offline

danv

Forum User
Junior
Registered: 08/30/04
Posts: 22
The config.php is solid. There are no instances of machinename.local anywhere in it. The site_url is set to 'http://IP address', and the other cookie settings are the standard defaults.

Other than the login problem on Safari, the site works fine - no images missing or anything else that would indicate a problem in the config.php.

Since Rendezvous has been disabled, I can login with other browsers, regardless of OS. All OS X machines are 10.3. Safari can browse the site, but I can't login with it.

I'm using the IP address to connect to the site - and Safari can see the page, but it doesn't get a cookie (no cookies for the site show up in the cookie folder, yet Safari is configured to accept all cookies. I do get cookies from other sites.)

When connecting via Safari, and attempt to login, I can see the name of the user show up in the 'Who's Online' block, but I also still get the username/password form show up in the 'User Functions' block, and I don't have access to any pieces of the site that are not allowed for anonymous users.

This symptom is much the same as if I disable cookies on the other browsers. When they can't get the cookie they experience the same issue. This is what has been happening, even in the other browsers on OS X clients, before I disabled Rendezvous.

So my guess is that Safari is still communicating in some other protocol to the server machine - even with Rendezvous disabled. And I can demonstrate that Rend. is effectively disabled because I cannot browse to the site any longer by using machinename.local.

 Quote

Status: offline

macboy

Forum User
Junior
Registered: 06/10/04
Posts: 15
This is the same issue I was experiencing with Safari, and a Geeklog site that I was running on 10.2 Server. After login, the page refreshed and showed the login block again in the User Functions. It looked just like I was not logging in.... Checking the site in a different browser showed the user was indeed logged in (just like you described). After trying a few times, I noticed that if I did a shift-refresh after logging in that Safari redrew the pages correctly and the logged-in content appeared. I never went so far as to check the cookies folder, as the shift refresh solved my problem. (this is what I was talking about in our first few posts).

What exactly are your cookie session and cookie name lines? Can you paste them here?

$_CONF['cookie_session'] = 'gl_session';
$_CONF['cookie_name'] = 'geeklog';

Those are the samples.
 Quote

Status: offline

dewdoo

Forum User
Chatty
Registered: 01/03/04
Posts: 65
I have been running geeklog on my G4 400 "Sawtooth" w/Mac OS X Server not "client" successfully for about 3 years. As I remember I had the same problem trying to run my geek site on "Client Version" of OS X and I had the same problem with logging in. I changed over to Mac OS X Server and been running smoothly, except one thing.....I have to refresh my page twice to login, I believe this a chache issue in Safari. All other browsers worked fine and on the PC too.

On my Mac OS X Server, I had to turn on register_globals on in the php.ini and I turned off permformance cache off. I am using DynDNS.org hostname because I am am on a dynamic ip addy w/my internet provider. If there is anything I can do to help let me know......I gave u some tibits on how I got my Mac to host my Geeklog Site. Oh, one more thing. I also had to port foward 8080 to my site, because my provider has blocked port 80. Dunno if that makes a difference.

My site here
 Quote

Status: offline

macboy

Forum User
Junior
Registered: 06/10/04
Posts: 15
Hey danv, Haven't heard from you. Did you get it working?
 Quote

Status: offline

danv

Forum User
Junior
Registered: 08/30/04
Posts: 22
Well, pretty much. They've decided to use Mozilla - the shift-refresh didn't work, and my cookie settings are just standard - no more changes:


$_CONF['cookie_session'] = 'gl_session';
$_CONF['cookie_name'] = 'geeklog';
$_CONF['cookie_password'] = 'password';
$_CONF['cookie_theme'] = 'theme';
$_CONF['cookie_language'] = 'language';
$_CONF['cookie_lastvisit'] = 'LastVisit';
$_CONF['cookie_lastvisittemp'] = 'LastVisitTemp';

$_CONF['cookie_ip'] = 0;
$_CONF['default_perm_cookie_timeout'] = 604800;
$_CONF['session_cookie_timeout'] = 7200;
$_CONF['cookie_path'] = '/';
$_CONF['cookiedomain'] = ''; // e.g. '.example.com'
$_CONF['cookiesecure'] = 0;


So thanks for all of the help, I'm just having them use Mozilla, and that works, so it's good. If I can figure out the Safari problem eventually, then it would be good, too.

And, to dewdoo's point, yes, my register_globals is on, but I will have to check on 'performance cache' - switching to OSX server is not an option at this point.

Thanks again!
Dan
 Quote

AddictedToMac

Anonymous
In every test I did (I did many and couldn't duplicate your situation) if you use an ip address as your url you need to set your $_CONF['cookiedomain'] to your ip address for it to work with Safari.
 Quote

Status: offline

danv

Forum User
Junior
Registered: 08/30/04
Posts: 22
In every test I did (I did many and couldn't duplicate your situation) if you use an ip address as your url you need to set your $_CONF['cookiedomain'] to your ip address for it to work with Safari.


That has been tried, and documented above, to no avail. I did this before AND after disabling Rendezvous, and it did not seem to have an affect.

macboy was able to replicate the problem... so I don't know why you couldn't... are you using a OSX 10.3 client as your GL server?

The above copy/paste of my config.php is what I've reverted to when the other changes had no effect on Safari working.

Thanks for your reply.
 Quote

HazMatt

Anonymous
confused
I am having the same problem where my internal site can be acessed via windows using just the machine name, but you need machinename.local to get it on OS X. This is very frustrating. I have tried everything suggested, short of completely disabling rendevous. I really don't want to do that. Is there some other way? It sounds like I could upgrade to OS X server. Any other ideas?
 Quote

Status: offline

danv

Forum User
Junior
Registered: 08/30/04
Posts: 22
Quote by HazMatt: ...internal site can be acessed via windows using just the machine name, but you need machinename.local to get it on OS X. This is very frustrating. I have tried everything suggested, short of completely disabling rendevous.
I had to disable Rendezvous on the server (OSX client OS) in order to allow clients to log in, in a mixed OS9/OSX/Windows environment.

My question for you is, are you able to log in, once you've hit the site, on either Windows or OSX?

In my case, I was trying to access the server by IP address, and was unable to login with OSX at all when using machinename as the site_URL in config.php. I had to match the site_URL to the Rendezvous name (machinename.local) to get OSX clients to log in - but then the OS9 and Windows clients couldn't login.

What is your site_URL set to?

If it's just set to machinename, and you can still login with OSX and Windows clients, you're in better shape than I was... maybe you will end up helping me!
 Quote

Page navigation

All times are EST. The time is now 11:56 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content