Welcome to Geeklog, Anonymous Tuesday, January 31 2023 @ 10:49 pm EST

Geeklog Forums

SMTP Email Problem


Status: offline

rjrufo

Forum User
Regular Poster
Registered: 06/14/03
Posts: 95
I'm using the smtp email for my GL installation, and it works great - if I want to send out one email at a time. When I try to send out an email using the mail utility to the Logged-in Users group, it will consistently send 18 emails, and fail the rest. I've tried a couple of ISP's with the same results. I believe that the failures are caused by too many smtp connections within a given time frame. Is there any way to put a delay in between emails? I'm not really worried about how long it takes to get all the emails out, but it is important for all of them to get to their recipient.

Any help would be greatly appreciated.
 Quote

Status: offline

mthomas

Forum User
Full Member
Registered: 04/18/04
Posts: 148
max_execution_time in the PHP.ini try increasing this value say to 900

If a PHP script take longer than x time it will terminate the thread, increase the time to allow for a longer exicution time.

Alternatively someone could hack the mail funtion to send all emails at ounce and use BCC to hide the email addresses.
 Quote

Status: offline

rjrufo

Forum User
Regular Poster
Registered: 06/14/03
Posts: 95
Thanks, I'll have to try increasing max_execution_time, I don't know if it will help, but it's worth a shot.

I don't know if I can hack the mail function, since I still don't know a lot about php, but I'll look into it to see what I can do. If you - or anyone else - can point me in the right direction, I'll take a stab it it.
 Quote

Status: offline

rjrufo

Forum User
Regular Poster
Registered: 06/14/03
Posts: 95
It seems that increasing max_execution_time did the trick. I'd still like to see what I can do with the mail function, but that will probably have to wait until I learn a little more.

Thanks for the suggestion mthomas.
 Quote

Status: offline

mthomas

Forum User
Full Member
Registered: 04/18/04
Posts: 148
Alternatively you might try using an external mail server? Or is that what your doing?

I'll take a look at the mail function too.
 Quote

Status: offline

rjrufo

Forum User
Regular Poster
Registered: 06/14/03
Posts: 95
I am using an external mail server. I don't have sendmail, and the PEAR mail function has never worked, so I've been using my ISP's mail server. It has always worked fine for individual emails, but I could never seem to send mail to the Logged-in Users group - at least not to all of them. Increasing the max_execution_time apparently was what I needed to do, because it works fine now. I didn't go as high as you suggested, but set it to 300. I figured that it shouldn't take five minutes to send out less than 200 separate emails, but I may have to increase it again as the site grows.

Again, thanks for your help. If you hack the mail function to send one email to the group using BCC, please post it here. I'm sure that I'm not the only one that would like to do the same thing.
 Quote

All times are EST. The time is now 10:49 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content