Welcome to Geeklog Sunday, November 28 2021 @ 12:27 pm EST

Geeklog Forums

Installed fine but now errors


Problem

Anonymous
ok i installed it fine and logged in but when i click on anything its like the page doesnt exist . I log in as admin click get published or any link and its like they dont exist but the files are all there
 Quote

problem

Anonymous
also i checked register globals in on
 Quote

problem

Anonymous
ok sorry for triple posting but i can edit my old posts when i checked php info the only things that r off is
always_populate_raw_post_data Off Off
asp_tags Off Off
define_syslog_variables Off Off
display_startup_errors Off Off
ignore_repeated_errors Off Off
ignore_repeated_source Off Off
ignore_user_abort Off Off
implicit_flush Off Off
log_errors Off Off
safe_mode Off Off
magic_quotes_runtime Off Off
magic_quotes_sybase Off Off
safe_mode_gid Off Off
sql.safe_mode Off Off
track_errors Off Off
Directive Local Value Master Value
allow_call_time_pass_reference On On
allow_url_fopen On On
always_populate_raw_post_data Off Off
arg_separator.input & &
arg_separator.output & &
asp_tags Off Off
auto_append_file no value no value
auto_prepend_file no value no value
browscap no value no value
default_charset no value no value
default_mimetype text/html text/html
define_syslog_variables Off Off
disable_classes no value no value
disable_functions no value no value
display_errors On On
display_startup_errors Off Off
doc_root no value no value
docref_ext no value no value
docref_root no value no value
enable_dl On On
error_append_string no value no value
error_log no value no value
error_prepend_string no value no value
error_reporting 2039 2039
expose_php On On
extension_dir ./ ./
file_uploads On On
gpc_order GPC GPC
highlight.bg #FFFFFF #FFFFFF
highlight.comment #FF9900 #FF9900
highlight.default #0000CC #0000CC
highlight.html #000000 #000000
highlight.keyword #006600 #006600
highlight.string #CC0000 #CC0000
html_errors On On
ignore_repeated_errors Off Off
ignore_repeated_source Off Off
ignore_user_abort Off Off
implicit_flush Off Off
include_path .:/usr/local/lib/php .:/usr/local/lib/php
log_errors Off Off
log_errors_max_len 1024 1024
magic_quotes_gpc On On
magic_quotes_runtime Off Off
magic_quotes_sybase Off Off
max_execution_time 30 30
max_input_time -1 -1
open_basedir no value no value
output_buffering no value no value
output_handler no value no value
post_max_size 8M 8M
precision 14 14
register_argc_argv On On
register_globals On On
report_memleaks On On
safe_mode Off Off
safe_mode_exec_dir no value no value
safe_mode_gid Off Off
safe_mode_include_dir no value no value
sendmail_from me@localhost.com me@localhost.com
sendmail_path /usr/sbin/sendmail -t -i /usr/sbin/sendmail -t -i
serialize_precision 100 100
short_open_tag On On
SMTP localhost localhost
smtp_port 25 25
sql.safe_mode Off Off
track_errors Off Off
unserialize_callback_func no value no value
upload_max_filesize 10M 10M
upload_tmp_dir no value no value
user_dir no value no value
variables_order EGPCS EGPCS
xmlrpc_error_number 0 0
xmlrpc_errors Off Off
y2k_compliance Off Off

register globals is fine though
 Quote

problem

Anonymous
http://vsheroes.freelinuxhost.com/geeklog/public_html/submit.php?type=story that doesnt exist for some reason
 Quote

problem

Anonymous
ok last time
http://vsheroes.freelinuxhost.com/geeklog/public_htmlgeeklog/public_html/admin/user.php see the path is all botched up can someone help me
 Quote

Status: Banned

machinari

Forum User
Full Member
Registered: 22/03/04
Posts: 1512
do you think that your paths and url in the config file may be off a bit?

check $_CONF['site_url'] , $_CONF['path_html'] , $_CONF['path'] .
 Quote

problem

Anonymous
/ This should point to the directory where your config.php file resides.
$_CONF['path'] = '/home/www/vsheroes.freelinuxhost.com/geeklog/'; // should end in a slash

// You only need to change this if you moved or renamed the public_html
// directory. In that case, you should specify the complete path to the
// directory (i.e. without the $_CONF['path']) like this:
// $_CONF['path_html'] = '/home/www/vsheroes.freelinuxhost.com/geeklog/';
$_CONF['path_html'] = $_CONF['path'] . 'public_html/';
 Quote

Status: Banned

machinari

Forum User
Full Member
Registered: 22/03/04
Posts: 1512
and your $_CONF['site_url'] ?

oh, and did you put a domain name in your path (vsheroes.freelinuxhost.com)? or is that actually a directory?
If that is a directory acting as a subdomain, then just one more question, where is your main index.php file residing?
 Quote

problem

Anonymous
// Some hosting services have a preconfigured admin directory. In that case,
// you need to rename Geeklog's admin directory to something like "myadmin"
// and change the following URL as well. Leave as is until you experience any
// problems accessing Geeklog's admin menu.
$_CONF['site_admin_url'] = $_CONF['site_url'] geeklog/public_html/admin';

// This is the return address for all email sent by Geeklog:
$_CONF['site_mail'] = 'truplaya21x@yahoo.com';

// Name and slogan of your site
$_CONF['site_name'] = 'Vs Heroes';
$_CONF['site_slogan'] = 'Where Heroes are born!';
thats it what did i do wrong
 Quote

Status: Banned

machinari

Forum User
Full Member
Registered: 22/03/04
Posts: 1512
here is the short version:

your $_CONF['path_html'] should read

PHP Formatted Code
$_CONF['path_html'] = '/home/www/vsheroes.freelinuxhost.com/';


 


You have yet to check your $_CONF['site_url']
 Quote

problem

Anonymous

Parse error: parse error in /home/www/vsheroes.freelinuxhost.com/geeklog/config.php on line 91

Warning: main(classes/timer.class.php): failed to open stream: No such file or directory in /home/www/vsheroes.freelinuxhost.com/geeklog/public_html/lib-common.php on line 114

Fatal error: main(): Failed opening required 'classes/timer.class.php' (include_path='.:/usr/local/lib/php') in /home/www/vsheroes.freelinuxhost.com/geeklog/public_html/lib-common.php on line 114
 Quote

Status: offline

hidden

Forum User
Chatty
Registered: 13/11/03
Posts: 51
in lib-common.php you have not set properly the path of your config.php.


we are just shadows of our hidden identities
 Quote

Status: offline

hidden

Forum User
Chatty
Registered: 13/11/03
Posts: 51
in lib-common.php you have not set properly the path of your config.php.


oh sorry for the double post...

edited*

we are just shadows of our hidden identities
 Quote

Status: Banned

machinari

Forum User
Full Member
Registered: 22/03/04
Posts: 1512
dude. where are you running geeklog? where does your main index.php file reside?

http://vsheroes.freelinuxhost.com or
http://vsheroes.freelinuxhost.com/geeklog/public_html

make your path accordingly and directory structure to boot.
 Quote

problem

Anonymous

require_once( '/home/www/vsheroes.freelinuxhost.com/geeklog/config.php' );

whats wrong with that
 Quote

problem

Anonymous
http://vsheroes.freelinuxhost.com/geeklog/public_html
thats where im running geeklog
 Quote

Status: offline

JohnVanVliet

Forum User
Full Member
Registered: 09/10/03
Posts: 161
i run windows but it looks like

require_once( '/home/www/vsheroes.freelinuxhost.com/geeklog/config.php'
is wrong
in lib-common
require_once( '/home/www/geeklog/config.php' );

and in
config.php

// Note for Windows users: It's safe to use the forward slash '/' instead of
// the backslash '' in paths. Make sure each path starts with a drive letter!

// This should point to the directory where your config.php file resides.


$_CONF['path'] = '/home/www/geeklog/'; // should end in a slash

// You only need to change this if you moved or renamed the public_html
// directory. In that case, you should specify the complete path to the
// directory (i.e. without the $_CONF['path']) like this:
// $_CONF['path_html'] = '/path/to/your/public_html/';
$_CONF['path_html'] = $_CONF['path'] .'public_html/';


// +---------------------------------------------------------------------------+
// | (3) Site Settings |
// +---------------------------------------------------------------------------+

// Make sure this is the correct URL to your site, i.e. to where Geeklog's
// index.php file resides (no trailing slash).

$_CONF['site_url'] = 'http://your-site address .com';



and have a look at apache's doc on v-hosting

here_@ http://httpd.apache.org/docs-2.0/vhosts/
 Quote

All times are EST. The time is now 12:27 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content