Welcome to Geeklog, Anonymous Wednesday, August 17 2022 @ 12:47 am EDT

Geeklog Forums

Image Upload to Gallery Problem


Status: offline

morech

Forum User
Junior
Registered: 06/24/04
Posts: 18
confused
I was uploading images to my website today. I am running Gallery 1.4.1. My site is www.mroech.com...

When i upload i get these errors. I dont' understand what they are and why. It was working 2hrs ago.




Processing status...

Warning: exec() has been disabled for security reasons in /home/httpd/vhosts/morech.com/httpdocs/gallery/platform/fs_unix.php on line 34

Warning: sort() expects parameter 1 to be array, null given in /home/httpd/vhosts/morech.com/httpdocs/gallery/util.php on line 2421

Warning: Invalid argument supplied for foreach() in /home/httpd/vhosts/morech.com/httpdocs/gallery/util.php on line 2424

Warning: Invalid argument supplied for foreach() in /home/httpd/vhosts/morech.com/httpdocs/gallery/util.php on line 2465
No images uploaded!


I looked here and in the faq and found nothing that could help me.... HELP!

Thanks in Advanced.
 Quote

Status: offline

destr0yr

Forum User
Full Member
Registered: 07/06/02
Posts: 324
Quote by morech: I was uploading images to my website today. I am running Gallery 1.4.1. My site is www.mroech.com...

Use an up to date version of Gallery that has GL integration, such as 1.4.3-pl2 or 1.4.4-RC2. I'd suggest 1.4.4-RC2 as the uploading integration actually works on a regular basis. 1.4.3 had some issues with applet uploads.
-- destr0yr
"I love deadlines. I like the whooshing sound they make as they fly by." -- Douglas Adams
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Quote by morech: Warning: exec() has been disabled for security reasons in /home/httpd/vhosts/morech.com/httpdocs/gallery/platform/fs_unix.php on line 34

Gallery will try to execute a helper application (either ImageMagick or NetPBM) to scale the images. But it looks like your hosting service has disabled the execution of external programs.

You'll probably have the same problem when trying to use image scaling in Geeklog or when creating a backup of the Geeklog database.

Try asking your hosting service to remove that restriction.

bye, Dirk
 Quote

All times are EDT. The time is now 12:47 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content