Welcome to Geeklog Saturday, November 27 2021 @ 03:27 am EST

Geeklog Forums

End of the rope here...


Status: offline

Don

Forum User
Full Member
Registered: 09/06/04
Posts: 153
I've been trying to get the mail functions on my first GL site to work for over a month now, and I am crying 'uncle.'

I'm trying to set it up with smtp. I've set it up according to what my hosting company says.

When i try sending a test email to myself, the mail does not send, and the page does not refresh - all i get is a blank page, no header, no nothing.

What am I missing? Anyone?

The site in question is http://www.blah3.com

Any help will get you a standing ovation and I'll buy you a beer.

-Don
 Quote

ironmax

Anonymous
Have you checked your error.log and does it say anything in there at all about what could be causing this?

I get the samething when trying to input a new user and then I try the same user again, it says that "The username or email address provided already exists" And I do not get an email. Check your mail route. You may want to try using the default for "mail" in the config.php file to help rull out something in that area. Also varify that you have your php.ini config file setup for your mail routine.
 Quote

Status: offline

Don

Forum User
Full Member
Registered: 09/06/04
Posts: 153
I don't have access to php.ini - gotta talk to the hosting guy about that, i guess...

Thanks for the suggestion.

-Don
 Quote

Status: offline

ldfoo

Forum User
Junior
Registered: 10/05/04
Posts: 34
Hi

Try ' localhost ' for the host instead of 'mail.mydomain.com'
 Quote

Status: offline

Don

Forum User
Full Member
Registered: 09/06/04
Posts: 153
Here are his settings in php.ini:

[mail function]
;for Win32 only
SMTP = localhost
sendmail_from = me@localhost.com

That oughta do it, right?

-Don
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Actually, if you're going to use SMTP, you should configure it in Geeklog's config.php, not in your php.ini (assuming your running Geeklog 1.3.9). Also see the FAQ.

bye, Dirk
 Quote

Status: offline

Don

Forum User
Full Member
Registered: 09/06/04
Posts: 153
I only posted the lines from php.ini because someone upthread mentioned that it was worth checking.

Here's how it currently looks in my config.php:

$_CONF['mail_settings'] = array (
'backend' => 'smtp', // can be one of 'mail', 'sendmail', 'smtp'

// sendmail parameters (for 'backend' => 'mail')
'sendmail_path' => '',
'sendmail_args' => '',

// SMTP parameters (for 'backend' => 'smtp')
'host' => 'localhost',
'port' => '25',
'auth' => 'false',
'username' => '',
'password' => ''

I've tried it with the actual mail server name (mail.blah3.com). With password and user name and without. Tried using GL's 'mail' function. Even created a new email account on my domain and tried *that* user name and password.

And I'm still greeted with a blank white page when I try sending a test email.

What little hair i have left is about to be pulled out, because i can't imagine what else to try here.

-Don
 Quote

Status: offline

Don

Forum User
Full Member
Registered: 09/06/04
Posts: 153
I should add - everything else on this site works great, and on the other GL site I've set up (http://www.takebackthemedia.com), the mail functions work perfectly. The only differece is that TBTM is on a FreeBSD server and Blah3 is on a Win server. I even tried copying over the same setup from TBTM (with different domains, of course) to Blah3, and that didn't work, either.

Could there be a corrupted file or something? I've got 180 users signed up, and I've had to process all of their passwords manually.

-Don
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Quote by Don: And I'm still greeted with a blank white page when I try sending a test email.

There seem to be cases where the PEAR classes are not picked up properly (or at all). Things you could try:

  • set $_CONF['have_pear'] = true;
  • enable the CUSTOM_mail() function in lib-custom.php
  • in COM_isMail and COM_mail (in lib-common.php) add the actual path to the PEAR directory in the include_once and require_once directives there.

I had a similar case recently, but that server also had register_globals=off at that time, so that may have caused problems, too.

Which version of PHP are you running?

bye, Dirk
 Quote

Status: offline

comicbookguy

Forum User
Regular Poster
Registered: 15/05/04
Posts: 97
I had the same problem when i set up my 1.3.9 geeklog. The last comment at the end of this thread solved the problem for me. I know of a few people who have applied this fix as well. I should mention that I am using SMTP.

Good luck.

www.PlanetDouglas.com
 Quote

Status: offline

Don

Forum User
Full Member
Registered: 09/06/04
Posts: 153
I'm running PHP 4.3.4.

I tried all of the suggestions above and still get nothing.

I set $_CONF['have_pear'] = true;

Tried hard-coding the return address in lib-common.php

The paths to the PEAR directory apparently already exist in the include_once and require_once directives in lib-common.php:

include_once( 'system/pear/Mail.php' );
include_once( 'system/pear/Mail/RFC822.php' );

---

A couple of other things:

If I leave out a recipient or leave the message field or body text blank, I get a prompt telling me to fill out all fields.

If I try to send a message to 'Root,' i get the following:

"Successfully sent 0 messages and unsuccessfully sent 0 messages. If you need them, the details of each message attempts is below. Otherwise you can Send another message or you can go back to the administration page.
Failures
No failures
Successes
No successes"

If I try to send to any other groups or Admins, i get a blank page.

I appreciate all the suggestions. I'm quickly getting discouraged over here, tho.

-Don
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Quote by Don: include_once( 'system/pear/Mail.php' );
include_once( 'system/pear/Mail/RFC822.php' );

These are relative paths - try using absolute paths.

bye, Dirk
 Quote

Status: offline

Don

Forum User
Full Member
Registered: 09/06/04
Posts: 153
Using absolute paths gives me this error:

"Fatal error: Undefined class name 'mail' in d:websitesblah3.comwwwlib-common.php on line 3198"
 Quote

Status: offline

comicbookguy

Forum User
Regular Poster
Registered: 15/05/04
Posts: 97
Not to sound over simplistic, but have you tried looking in your GL's error log? The log can be found in the log directory usually off the root. It should give you a better idea of what is going on.

BTW the last thing I did to get my email to work was to set:
PHP Formatted Code
$_CONF['have_pear'] = false;
 
 Quote

Status: offline

Don

Forum User
Full Member
Registered: 09/06/04
Posts: 153
I keep forgetting to mention that!

Nothing is showing up in my error logs regarding mail errors.

Thanks again for being helpful.

-Don
 Quote

Status: offline

comicbookguy

Forum User
Regular Poster
Registered: 15/05/04
Posts: 97
Are you not getting any errors in your error log?
 Quote

Status: offline

ldfoo

Forum User
Junior
Registered: 10/05/04
Posts: 34
Hi

I was also tearing my hair out earlier this week until the hosting service did a U turn on their previous instructions.

in the config settings, I had to set the host to 'localhost' (as Dirk had initially suggested to me) - The auth needed to be 'true' and the user name is an email address xxxx@xxxx.com (I had made the mistake of using the site admin login) and password is the email password.

My pear setting is 'true'

I'm not sure whether the sendmail path needs to be set if you are using 'smtp' - I put it in as directed anyway.

rgds
 Quote

All times are EST. The time is now 03:27 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content