Welcome to Geeklog Monday, May 16 2022 @ 01:31 am EDT

Geeklog Forums

Escaped Double Quotes


Status: offline

MikeMcArthur

Forum User
Newbie
Registered: 29/05/04
Posts: 1
confused
I have a new Geeklog 1.3.9 installation on my web site:

http://www.mikemcarthur.net

And it appears to be running pretty well.... BUT

It seems that every time I hit a page on the site for the first time I get something very strange and ugly... It looks like THIS

http://www.mikemcarthur.net/bad-2.html[


Instead of THIS

http://www.mikemcarthur.net/good-2.html[

Hitting the reload button on the browser will bring the page up in all its glory, and I won't see the problem again... until I go to another part of the site for the first time, with a given client.

The difference between the "bad" html and the "good" html appears to be that in the "bad" html, all the double-quotes (") have been escaped with a backslash.

I've run diff on my config.php and lib-common.php with the files from the tarball, and it doesn't look like I put in any mismatched quote marks in there. Or anything else that isn't supposed to be there.

Is there a patch for this? What am I missing?
 Quote

Status: offline

mthomas

Forum User
Full Member
Registered: 18/04/04
Posts: 148
hmm just for informations sake Windows or Mac/Linux?
Webserver and version of php?
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Make sure you have magic_quotes_runtime set to "off" in your php.ini. But I guess it already is, or you would get the "bad" display on every page.

Also, you seem to be running Apache 2.0.40 - you may want to upgrade that to the current version (the same goes for your PHP version). We had a few reports of problems with early versions of Apache 2 and PHP, but I haven't heard of any such problems recently.

bye, Dirk
 Quote

MikeMcArthur

Anonymous
cheerful
Actually upgrading Apache and PHP to fix this issue is something I will have to wait for my friendly neighborhood sysadmin to get around to, as I don't own the server.

Thanks for the information. I was afraid I'd made a mistake in setting up GeekLog itself.




 Quote

All times are EDT. The time is now 01:31 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content