Welcome to Geeklog Sunday, November 28 2021 @ 11:59 am EST

Geeklog Forums

Download directory question


Status: offline

viss

Forum User
Junior
Registered: 25/03/04
Posts: 23
Hey guys,

I have a question about where I store my downloads. Geek is installed on my c:/ drive and all my downloads are stored on my d:/ drive. Now when you add a download by default the directory is C:/Aeonserv/geeklog/public_html/filemgmt_data/files/ when you add a download it then saves to the c:/ drive in the above directory doubling the file in my case as I already have it. My question is can I link my files directly to the D:/ drive and how should I go about doing this. I also have a ftp server running could I create a user and pass and get geek to log straight into the ftp to stop leeching ?

your help would be appreciated

Viss

Ps the site is coming along nice Check it out here
 Quote

Status: offline

viss

Forum User
Junior
Registered: 25/03/04
Posts: 23
Hello this is not a hard question really Confused
 Quote

Status: offline

Turias

Forum User
Full Member
Registered: 20/10/03
Posts: 807
I was going to try answering this before, but I didn't have a windows box in front of me at the time. In linux, your problem would be solved as simple as creating a soft link from the filemgmt_data directory to a similarly setup directory on your D: drive. Thus, the webserver would continue to function as normal except all of the data would actually be on your D drive.

I don't use Windows that often, but I was not able to replicate this with a Windows shortcut. Is it possible to make soft links on windows?

Anyway, I have another idea you can try:
Add another webroot/alias so that http://yourhost/filemgmt_data/ actually points to a directory on d:. Then, set that directory up as you would your normal filemgmt_data directory. Then, when you upload files (assuming your permissions are correct), they should get stuck in d:
 Quote

Status: offline

viss

Forum User
Junior
Registered: 25/03/04
Posts: 23
This is somthing that I feel really needs to be addressed in the next release. I run my server localy and all my files are obviosly on the same server, there needs to be a feature in the file management to use local files its a bit silly that I have to upload my own files from my server to my server, dosent make sense really. And im trying to upload a 15 mb file and im having a hell of a time getting it to work.

Viss
 Quote

Status: offline

Turias

Forum User
Full Member
Registered: 20/10/03
Posts: 807
As a work-around, try uploading a really small file (a placeholder) and then replacing that small file with your large one.
 Quote

Status: offline

viss

Forum User
Junior
Registered: 25/03/04
Posts: 23
Ok will do. How do I check permissions im getting error code 1017
 Quote

Status: offline

viss

Forum User
Junior
Registered: 25/03/04
Posts: 23
Hello !!!! why am I getting this error now ? Ive uploaded 1 file now I cant upload any more ?/???
 Quote

Status: offline

viss

Forum User
Junior
Registered: 25/03/04
Posts: 23
Well ive just about had enough Angry Ive been waiting on a reply all day and nothing not a real good way to run things guys. I think Ill pull the pin and go back to nuke at least you get some support there Frown
 Quote

Status: offline

Turias

Forum User
Full Member
Registered: 20/10/03
Posts: 807
You can't expect everyone to jump on your questions between 11PM and 4AM on a friday night. Some of us do have social lives. I've already tried to help you twice in this thread. I would appreciate it if you didn't resort to the classic "I'm going back to nuke because no one is helping me" threat.

Anyway, you need to make sure that the correct directories are writable by your webserver. Check the install documentation for the plugin and it will tell you which ones. Do the same things to those directories that you had to do to images/userphotos and images/articles on geeklog's install.
 Quote

Status: offline

viss

Forum User
Junior
Registered: 25/03/04
Posts: 23
Frown sorry dude I didnt realize it was that time Oops! I loggged in with my ftp client chmod'd the folder 666 and still no go. Ill have a read and see what it says.

Viss
 Quote

Status: offline

Turias

Forum User
Full Member
Registered: 20/10/03
Posts: 807
Create the following directories for the filestore


Under your webserver document root directory - create the following directories.


o        filemgmt_data


o        filemgmt_data/files


o        filemgmt_data/files/tmp


o        filemgmt_data/snaps


o        filemgmt_data/snaps/tmp


o        filemgmt_data/category_snaps


Note1: You may use different names - they will be set in the plugin config file


Note2: The tmp directory is where non FileMgmt-Admin users who submit files are stored until approved


Note3: The snap directories are used to store the thumbnail images


3.2            Set directory ownership to that of your webserver on all module directories and files - including data directory.


eg: chown -R www:www filemgmt_data


Set permissions on directories and files to 754


Need to allow write permissions for Webuser to filemgmt_data directory


if 754 doesnt work, make them all 777.
 Quote

Status: offline

viss

Forum User
Junior
Registered: 25/03/04
Posts: 23
Awww this is killing me Cry how the hell are you supposed to chmod a file on your local drive I changed all the download directory to d: drive instead of c: default because I have a ftp server running and I could log in and chmod, Ive changed all the directories back to default and now I dunno how to chmod them ?? Cry

Suiside me be the next option.
 Quote

Status: offline

Turias

Forum User
Full Member
Registered: 20/10/03
Posts: 807
Can you do it from the command line? Or from the properties window? I know that window has some permissions info. I've never used Windows as a server environment. I'd do some googling, if I were you.
 Quote

Status: offline

viss

Forum User
Junior
Registered: 25/03/04
Posts: 23
Ok guys Ive done alot of reading and Ive learnt how to set folder permissions and still no luck. surely there is another windows user that has had this problem, someone give me some wisdom Cry
 Quote

Status: offline

viss

Forum User
Junior
Registered: 25/03/04
Posts: 23
freakingout
Ok it appears I have made some progress after checking the install log it seems to be an error with the thumbnail that is stopping the upload, If I leave the thumbnail out the file uploads fine. I have checked permissions on the images folder and thay are fine but It still dont work this is the message

4/7/2004 2:05:46 PM - Filemgmt File add by admin error: New file could not be created: C:WINDOWSTEMPphp1C.tmp to dvdauth.GIF

Next thing is I uploaded a 20 kb dummy rar file and then replaced it with the 11mb file and tried to download it and it com up as page cannot be displayed, I changed the file size on the download to suit and that didnt fix it either ? any suggestions ?

Viss
 Quote

Status: offline

jameslee

Forum User
Newbie
Registered: 07/04/04
Posts: 1
Hi, I've only just entered the world of php and CMS sites and I just installed my first GL plugin ever, namely Blaine's download plugin, which I can't wait to get working! Problem is, after installation I get the following error

"Error Code: 1102
ERROR: Upload submit Error: The temporary filestore file was not created. Check error.log"

the error log tells me...
"Wed Apr 7 01:03:58 2004 - Filemgmt submit error: Temporary file could not be created: /tmp/phpS845Ji to g:/wwwroot/geek138_7/public_html/filemgmt_data/files/tmp/bSelzS6kks"

For your info...

I have installed GL in my site hosted by SRLnet.com, so I'm confused with the config settings asking for a local directory eg "g:/wwwroot...etc". Also changes I make to config settings don't actually change so I know I havn't done step 3.2 of the install doc (the reason being I don't understand what it means and how to do it)

Could someone please explain how to do step 3.2 and I would be very grateful and should be able to work out the rest. VISS, maybe you could fill me in on setting the folder permissions bit Big Grin BTW- I normally use dreamweaver, ftp commander or similar to ftp.

Thanks, from a newbie Oops!
 Quote

Status: offline

viss

Forum User
Junior
Registered: 25/03/04
Posts: 23
From what I can gather is your site is hosted (not on your pc) you need to log into your favorite ftp program and you need to chmod the files, this is setting the file permissions which enable reading and writimg of files. If you look further back in this tread you will see what numbers to use. If you need help with Dreamweaver look in the help files for chmod or google search (how to chmod files with dreamweaver) this should help. Ohh and by the way the files you need to chmod are also listed in this post.

Good luck Viss Laughing Out Loud
 Quote

All times are EST. The time is now 11:59 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content