Welcome to Geeklog, Anonymous Tuesday, November 29 2022 @ 03:57 am EST

Geeklog Forums

GeekLog Basedir Error


Mike

Anonymous
Just tried to install GeekLog on a PLESK 7 system. I followed all of the install info in the guide. PLESK has a non world accessible folder called private, so I changed the paths and uploaded everything via FTP, then set the permissions to 775 where needed.

Here is the error I get when I go to check.php:

Warning: main(): open_basedir restriction in effect. File(/home/httpd/vhosts/mysite.com/private/config.php) is not within the allowed path(s): (/home/httpd/vhosts/mysite.com/httpdocs:/tmp) in /home/httpd/vhosts/mysite.com/httpdocs/lib-common.php on line 69

Warning: main(/home/httpd/vhosts/mysite.com/private/config.php): failed to open stream: Operation not permitted in /home/httpd/vhosts/mysite.com/httpdocs/lib-common.php on line 69

Fatal error: main(): Failed opening required '/home/httpd/vhosts/mysite.com/private/config.php' (include_path='.:/php/includes:/usr/share/pear') in /home/httpd/vhosts/mysite.com/httpdocs/lib-common.php on line 69
 Quote

Mike

Anonymous
I contacted my host and the basedir error has been fixed (they said they forgot to put the folder in the Apache openbasedir directive), but I still get these errors:

Warning: main(/home/httpd/vhosts/securityseeker.com/private/config.php): failed to open stream: Permission denied in /home/httpd/vhosts/securityseeker.com/httpdocs/lib-common.php on line 69

Fatal error: main(): Failed opening required '/home/httpd/vhosts/securityseeker.com/private/config.php' (include_path='.:/php/includes:/usr/share/pear') in /home/httpd/vhosts/securityseeker.com/httpdocs/lib-common.php on line 69
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Make sure you've set the permissions to config.php and that "private" directory such that your webserver can read them ...

bye, Dirk
 Quote

Status: offline

PerS

Forum User
Newbie
Registered: 02/15/04
Posts: 1

I had the same problem on Plesk 7, I fixed if by adding the following to my /home/httpd/vhosts/DOMAIN.TLD/conf/vhost.conf file

<Directory /home/httpd/vhosts/DOMAIN.TLD/httpdocs>
php_admin_value open_basedir "/home/httpd/vhosts/DOMAIN.TLD/httpdocs:/home/httpd/vhosts/DOMAIN.TLD/geeklog:/tmp"
</Directory>

rgds,
Per
 Quote

chaz

Anonymous
awake
Having the same problem evil when its in public_html Frown
 Quote

Joe

Anonymous
gloomy
Security be damned fix:

This maybe harmful but being alot of hosts I have been on tend not to use the open_basedir directive anyways what the hell. This worked for me

Edit the conf/httpd.include file found in the folder containing the files for your site. You will need root access to do this.

Open the file httpd.include you should see something like this in the configuration for your site:


php_admin_flag engine on
php_admin_value open_basedir "/home/httpd/vhosts/some.com/httpdocs:/tmp"


change it to this:


php_admin_flag engine on
php_admin_value open_basedir none

Now your geeklog should work just fine.
Not sure though but Plesk may fix this on reboot. I noticed that the file I edited got changed back after a reboot. Not sure if it was due to Plesk rewriting the file or some sort of restore of the file was done by a network technitian because the reboot was after a problem with the server which was unrelated to this.
 Quote

Din.

Anonymous
awake
Hi Joe,

You are right, PLESK will rewrite/overwrite the open_basedir again once you called a reboot via PLESK(browser). I'm still looking for this solution.

Well, if you can gain root access and SSH, you pretty much can modify the httpd.include and set the open_basedir none and type "service httpd restart" or "/usr/local/psa/admin/sbin/websrvmng -p", then it won't modified the conf. file, anyway it's just a temporary solution, I will post again if I have good news.

Din.
 Quote

Din

Anonymous
Now, with some helping hands and after reading articles, I have finally solved this problem, i.e. set open_basedir none
I am now able to restart the apache over PLESK web-base. with the open_basedir set to NO VALUE


1) if you are running normal HTTP, then place this information in
/home/httpd/vhost//conf/vhost.conf
<Directory /home/httpd/vhosts/[:: DOMAIN::]/httpdocs>
php_admin_value open_basedir none
</Directory>

2)if you are also running HTTPS, then place the same content on different file vhost_ssl.conf
<Directory /home/httpd/vhosts/[:: DOMAIN::]/httpdocs>
php_admin_value open_basedir none
</Directory>

*IMPORTANT* replace [:: DOMAIN::] with your domain dir.

3)on Shell type :
/usr/local/psa/admin/sbin/websrvmng -u --vhost-name=[:: DOMAIN::]

4) to verified, if this command works, vi the /home/httpd/vhost/[:: DOMAIN::]/conf/httpd.include

you will see "include /home/.../vhost.conf" or "include /home/../vhost_ssl.conf" (depend if you want your site to have HTTP/HTTPS service)

5) either you can restart your apache through shell command or you may restart it from the PLESK web-base.

Good luck , if you have any question, drop me a message.

[some reference]
http://download1.sw-soft.com/Plesk/...tures/ch06.html
 Quote

Deportivo

Anonymous
Is it possible to overwrite the open_basedir for subdomains too? I think it isn't because the Include /home/httpd/vhosts/DOMAIN.TLD/conf/vhost.conf line in httpd.include is called before the subdomain containers. So the settings in vhost.conf will be overwritten again. Is it just impossible, or is there another way which i haven't thought of?
 Quote

Status: offline

spockjuh

Forum User
Junior
Registered: 06/30/04
Posts: 32
ok, call me stupid, but i can't find it. im still stuck at the line warning: main open basedir restriction in effect.

Can some explane in a newbie way how to solve tis problem?? yes i know, i'm dumb..
 Quote

BlackOps

Anonymous
4PSA TotalDomains allows this...sort of. It creates subdomains UNDER the root httpdocs directory for the parent domain, so you can store configuration options for a subdomain's directory in vhost.conf and vhost_ssl.conf.
 Quote

BlackOps

Anonymous
Guess I should have said. I am running Plesk 7.0.2 on Fedora, and I have overcome this open_basedir problem multiple times using TotalDomains. I am not affiliated with 4PSA, but am a very satisfied user of several of their products. http://www.4psa.com/
 Quote

anon

Anonymous
thanks to anon above for syntax in vhost.conf
some people have a php bug that means
php_admin_value open_basedir none
doesn't work

This does work though in that case:
&lt;Directory /home/httpd/vhosts/[YOURDOMAIN/httpdocs&gt;
php_admin_value open_basedir /
&lt;/Directory&gt;



 Quote

Status: offline

samstone

Forum User
Full Member
Registered: 09/29/02
Posts: 820
Just saw this post. It was suggested that "/" should not be used as it might open up more directories than you want to. Better be specific, so it should be:

Text Formatted Code
<Directory /home/httpd/vhosts/domain.net/httpdocs>
php_admin_value open_basedir none
</Directory>

<Directory /home/httpd/vhosts/domain.net/httpdocs>
php_admin_value open_basedir /home/httpd/vhosts/domain.net
</Directory>

 


You also need to create one for vhost_ssl.conf changing httpdocs to httpsdocs.
 Quote

PixsouL

Anonymous
confused
Very helpfull posts. I changed the basedir in a clients virtual host settings to test the changes and it worked perfect. What I need to do now is try to figure out how to have the basedir set to none for all new virtual hosts automaticly. I also use Plesk7. What makes what I do a little different than a normal hosting service. I sell a hosted "service" not hosting account. So no one but me actually has access to the server. So im not worried about the security issues.

Anyone have any ideas on how to setup Plesk so that all new hosts are set to basedir none?

Any help would be appreciated :-)

Thanks in advance.

- Dave
 Quote

Status: offline

samstone

Forum User
Full Member
Registered: 09/29/02
Posts: 820
I gave up on Plesk as I ended up spending more time on sever than on production. I lost some money on the lincense, but now I save a great deal precious time by not having to deal with Plesk.

So, sorry for not being able to help!

Sam

 Quote

PixsouL

Anonymous
Thanks Sam, So far besides this problem I have really liked Plesk. I have another server with Anism, which seems really limited compaired to Plesk.

Does anyone have any ideas? Anything would be really appreciated.

You can email me at dave @ iprosa . com if you have any ideas :-) Thanks in advance.

- Dave
LenderSight.com
 Quote

Status: offline

samstone

Forum User
Full Member
Registered: 09/29/02
Posts: 820
There is a way to set it through httpd.conf, I guess, but I don't remember the detail right now. The problem is once you run an upgrade, Plesk would overwrite the settings, and mess up the websites. That's why Plesk requires the users to use vhost.conf within each domain because they don't overwrite these files.

There are other limitations of Plesk that hinder development of complex sites. I ended up having to overcome one hurdle after another. I use CPanel now and, even though it doesn't have a good looking interface it Plesk, it has more 'subtance' comparingly, and allows a great deal of freedom and flexibility.

One example. Like you, I provide hosting 'service,' and CPanel allows me to setup ftp on sub-directory, through which I can allow end user to have access to the layout directory and make changes to their desire, without letting them mess up the core GL codes. You can't do that with Plesk. I have requested Plesk to come up with that feature for years and never came to existance. Plesk is stuck in a shallow structure that disable them to be sophistcated.

As for Ensim...I don't know why they are still in the market.

Sam
 Quote

All times are EST. The time is now 03:57 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content