Welcome to Geeklog Friday, July 10 2020 @ 05:50 am EDT

Geeklog Forums

Paths: Multiple Geeklog installs on same server


Status: offline

xardoz

Forum User
Regular Poster
Registered: 24/02/04
Posts: 98
determined
Hi,
I have geeklog as my main site on my webserver, but I have several other users on my server who want to use it as well. I've got seperate databases and usernames for them, but I'm having problems with the paths.

I'm running this on a Novell Apache server, so the path for my main site config.php would be

sys:/Apache/htdocs/

Htdocs is not public, the path to the HTML/lib-common.php is

sys:/Apache/htdocs/web/

Web is my public directory, obviously. A standard user URL would be

http://www.mydomain.com/group/USERNAME

and a standard path to their html would be

sys:/Apache/htdocs/web/group/USERNAME

I want to keep all their config.php files outside my public WEB folder, so the path for config.php would then be

sys:/apache/htdocs/USERNAME/

The problem I'm having is when I try to specify that config.php is in sys:/apache/htdocs/USERNAME, the install tries to locate the public_html folder as sys:/Apache/htdocs/sys:/Apache/htdocs/web/group/USERNAME

Can I set up Geeklog this way, or should I just secure their USERNAME folder and place their config.php in it and then have a subfolder for their public_html?

Any help would be greatly appreciated.

Thanks!
 Quote

Status: offline

Turias

Forum User
Full Member
Registered: 20/10/03
Posts: 807
It looks like it's a simple problem with your $_CONF['path_html']

Make sure it looks like:

$_CONF['path_html'] = 'sys:/Apache/htdocs/web/group/USERNAME/';
 Quote

Status: offline

xardoz

Forum User
Regular Poster
Registered: 24/02/04
Posts: 98
Quote by Turias: It looks like it's a simple problem with your $_CONF['path_html']

Make sure it looks like:

$_CONF['path_html'] = 'sys:/Apache/htdocs/web/group/USERNAME/';


Did that, and the error I'm getting during installation is:
Template Error: set_root: sys:/Apache/htdocs/USERNAME/sys:/Apache/htdocs/web/GROUP/USERNAME/layout/XSilver is not a directory.
Halted.
 Quote

Status: offline

Turias

Forum User
Full Member
Registered: 20/10/03
Posts: 807
I can almost guarantee you that that is not your path_html. Geeklog is saying that your path_html is sys:/Apache/htdocs/USERNAME/sys:/Apache/htdocs/web/GROUP/USERNAME/

It looks like you are setting your path_html to $_CONF['path'] . 'sys:/Apache/htdocs/web/GROUP/USERNAME/'
 Quote

Status: offline

xardoz

Forum User
Regular Poster
Registered: 24/02/04
Posts: 98
Quote by Turias: I can almost guarantee you that that is not your path_html. Geeklog is saying that your path_html is sys:/Apache/htdocs/USERNAME/sys:/Apache/htdocs/web/GROUP/USERNAME/

It looks like you are setting your path_html to $_CONF['path'] . 'sys:/Apache/htdocs/web/GROUP/USERNAME/'


Oops! Do'h!

Forgot to pull hte $_CONF['path']

Thanks!
 Quote

All times are EDT. The time is now 05:50 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content