Welcome to Geeklog Saturday, December 07 2019 @ 06:17 am EST

Geeklog Forums

Static Pages error after 1.3.9 install


Status: offline

horkulated.com

Forum User
Newbie
Registered: 28/01/04
Posts: 10
"URL Class: number of names passed to setArgNames must be equal or greater than number of arguments found in URL"

Huh? I backed up my staticpages stuff, and reinstalled the staticpages plugin, just like Dirk said... what does this message mean??
Horkulated -- Where Great Ideas go to Die
 Quote

Status: offline

jef

Forum User
Junior
Registered: 26/07/03
Posts: 28
Rolling Eyes
Same prob here.. Tried install - reinstall.. Not workin'
It ain't easy being you
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Did you (both of you) replace the system/classes/url.class.php file?

bye, Dirk
 Quote

Status: offline

jef

Forum User
Junior
Registered: 26/07/03
Posts: 28
thoughtful
Well, this is a fresh install. The system/classes/url.class.php file I use is the one included in the tarball...

I've checked and compared with the 1.3.8 file and I found this difference:

Old 1.3.8

function setArgNames($names)
{
if (count($names) < count($this->arguments)) {
print "URL Class: number of names passed to setArgNames must be equal or greater than number of arguments found in URL";
exit;
}
if (is_array($names)) {
$newArray = array();
for ($i = 1; $i <= count($this->_arguments); $i++) {
$newArray[current($names)] = current($this->_arguments);
next($names);
next($this->_arguments);
}
$this->_arguments = $newArray;
reset($this->_arguments);
} else {
return false;
}
return true;
}

Compared to new 1.3.9

function setArgNames($names)
{
if (count($names) < count($this->_arguments)) {
print "URL Class: number of names passed to setArgNames must be equal or greater than number of arguments found in URL";
exit;
}
if (is_array($names)) {
$newArray = array();
for ($i = 1; $i <= count($this->_arguments); $i++) {
$newArray[current($names)] = current($this->_arguments);
next($names);
next($this->_arguments);
}
$this->_arguments = $newArray;
reset($this->_arguments);
} else {
return false;
}
return true;
}
----------------------------------
Actually, the only diff. is the missing "_" in front of the first "arguments". This is enough to gain acces to the static pages plugin admin page, but I get a 500 internal server error.. because it's calling .../admin/plugins/staticpages/index.php/edit
There is a serie of bugs there.. what function within that page shout it call to make it functionnal?

Thanks for your answer
It ain't easy being you
 Quote

Status: offline

thedude

Forum User
Regular Poster
Registered: 28/12/02
Posts: 90
So, what's the resolution to it? I'm still having that error. Please advise. Many thanks.
 Quote

Status: offline

thedude

Forum User
Regular Poster
Registered: 28/12/02
Posts: 90
Quote by Dirk: Did you (both of you) replace the system/classes/url.class.php file?

bye, Dirk


Please details Dirk. Replace it with what? Please advise. Many thanks.

The Dude
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Quote by thedude: Please advise.

This is an old thread - Geeklog 1.3.9sr1 shouldn't have that problem.

bye, Dirk
 Quote

Status: offline

thedude

Forum User
Regular Poster
Registered: 28/12/02
Posts: 90
Really... Hmmmm.....

Coz I'm using 1.3.9sr1 and I'm still having the same problem accessing the staticpages admin with the same error..

Please advise...

Thanks Dirk..

The Dude
 Quote

tokyoahead

Anonymous
I am getting the same problem now. I installed the rewrite-function now and the static page editor wont work anymore. calling editor of a page gives me the error:

http://tokyoahead.com/main/admin/plugins/staticpages/index.php/edit/newsmailer/

URL Class: number of names passed to setArgNames must be equal or greater than number of arguments found in URL

I think the edit-links should not use the rewrite. for the sotry edit, they dont:

http://tokyoahead.com/main/admin/story.php?mode=edit&sid=newsmailerannounce


I have the latest version, not customizing done on classes...
 Quote

Status: offline

Steven

Forum User
Newbie
Registered: 13/10/04
Posts: 10

See this thread.



Mechwars Robot Combat Webmaster www.tcmechwars.com Fight Robots Not People
 Quote

tokyoahead

Anonymous
Well sorry but this surely cannot be an answer. If there is a URL rewriting feature in geeklog, and all edit pages exept the static page ones work with it, switchign it simply off is not a proper solution, more a workaround.

specially if the problem is seemingly old and should be fixed already since some time ago. (not to mention the fact that I clearly stated that the link is not working because I switched on the rewriting)


 Quote

All times are EST. The time is now 06:17 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content