Welcome to Geeklog Tuesday, August 04 2020 @ 07:00 pm EDT

Geeklog Forums

Inserting Picture in a Story or Topic.

Page navigation


Status: offline

ola_one

Forum User
Full Member
Registered: 28/06/03
Posts: 186
awake
Hello all,

Can someone possibly give me a step by step lesson on how to insert a picture in Gallery to a story in Geeklog.

I have done this seversl times trying to follow the directions presented in Geeklog, but each time, it turns out to be a serious examination for me.

I often get errors and then without knowing what I did, it will show the picture.thumb in my story but the link would still be missing.

I need to understand how to first insert the picture, and secondly, link the picture back to the album it belongs to.

I know that I need to add the image by inserting [ImageX_left] in the story. But each time I do that, it seems I need to browse and add the picture first.

Please educate me, especially with the link back to the album.

Thank you all in advance.

Ola
 Quote

Status: offline

samstone

Forum User
Full Member
Registered: 29/09/02
Posts: 820
As you can see, there are usually 5 image uploading fields near the bottom of the story editor. What ever you browse and add in that first field is [images1], second [image2], etc.

So this is the procedure. You write the article and include a code [image1] [image2] [image3], etc. wherever you want in the story, and as you scroll down the page you add the image link by clicking on browse. At the end you click save. The images will be uploaded and placed at the place you put the codes.

Hope this helps!

Sam
 Quote

Status: offline

Turias

Forum User
Full Member
Registered: 20/10/03
Posts: 807
You're confusing inserting images into stories normally and doing the same thing with images already in Gallery. If you want a picture from Gallery to show up in a story, you should add it using simple HTML.

Do the following:
1) Get the URL for the thumbnail image
2) Get the URL for the gallery page which shows the complete image
3) Add the following into the story:

PHP Formatted Code
<a href="[gallery_page_link]"><img src="[thumbnail_image_link]" align="left|right|..." /></a>



 


Things to keep in mind:
1) Make sure that all of these tags and attributes are allowed for admins in your config.php file.
2) You need to post the story as HTML formatted
 Quote

Status: offline

samstone

Forum User
Full Member
Registered: 29/09/02
Posts: 820
That's right, I didn't see that he was talking about images from the Gallery.

Ola, the insturction on that story editing page is for inserting images from your computer, not from the Gallery.

Sam
 Quote

Status: offline

ola_one

Forum User
Full Member
Registered: 28/06/03
Posts: 186
Hello Again,

I know this may sound stupid, but when Turias said I needed to do three things, are all those accomplished by the html code:



The Gallery page link is the url to my gallery?
The Thumnail_image_link is the url to my thumbnail?

If the above are true, how do I link the specific thumbnail which is now part of my story to the rest of the album where the thumnail came from?

Would the code have done that for me?

Thanks again, I really appreciate all your help

Ola


 Quote

Status: offline

Turias

Forum User
Full Member
Registered: 20/10/03
Posts: 807
The HTML code merely displays an image that is already in the gallery. If you want to post an image in both the gallery and the story, then put it in the gallery first and find the links that I mentioned before.

If you don't care if the image is in the gallery and only want it to be in the story, then don't do what I said. Instead, attach the image through the story submission page.
 Quote

Status: offline

ola_one

Forum User
Full Member
Registered: 28/06/03
Posts: 186
Yes I want to insert the image from gallery. My question is that the html code that you game me does not mention the album name at all, I was trying to add an image to a story say for instance the image of a turkey to tell the story of thanksgiving, but when you click on the image of the turkey that I would have inserted in the story, it should then take you to the album named thanksgiving where the image came from in the first place.

Sorry if I was not clear with my initial question.

Thanks

Ola
 Quote

Status: offline

Turias

Forum User
Full Member
Registered: 20/10/03
Posts: 807
Right, and my first post still stands. You need the URL for the thumbnail image and the URL for the page that displays the entire image.

If that doesn't make sense, then give me the URL to your site and the image you want posted and I will find it for you.
 Quote

Status: offline

ola_one

Forum User
Full Member
Registered: 28/06/03
Posts: 186
Thanks again Turias,

I am in the process of changing registrar and in the next couple of days, my url may not work well.

What I found confusing is that the first part of the code you gave me, is referencing the gallery_page_link. Does this mean the album that the thumbnail is coming from?

This is one of those situations where I hope you say there is nothing like a stupid question.

But I have several albums in my Gallery right now, so what I am getting at is that the picture in the story gets linked to the album.

Am I saying the same thing or just not getting it?

Does that code mean link to the album on the gallery page?

Thanks again

Ola
 Quote

Status: offline

samstone

Forum User
Full Member
Registered: 29/09/02
Posts: 820
Hi Ola,

Changing the registrar should not affact your url.

Yes, the code Turias gave you also links to the gallary page.

Sam
 Quote

Status: offline

Turias

Forum User
Full Member
Registered: 20/10/03
Posts: 807
The 2 urls you need are the following:

1) Click on gallery. Click the gallery that contains your image. Find the thumbnail of your image. Right-click the thumbnail and find it's url.


2) Now click on the image. The page that appears is the second URL.

Now, if you use the code above, you can display thumbnails in the story, and then, when you click on the thumbnail, it will display the full image in the gallery.
 Quote

Status: offline

emagin

Forum User
Regular Poster
Registered: 05/08/03
Posts: 92
I just tried this. I pasted in the code as you specify and while it PREVIEWS the image just fine (I'm using HTML Area in the layout, so the thumbnail image shows up), when I go to save it and then look at the story the image is gone.

I tried this with other layouts (w/out HTML Area) and the same thing happens. No image shows up even though the HTML is in there.

Have you tested this? Do you have an online xample by chance?

Thanks
 Quote

Status: offline

Turias

Forum User
Full Member
Registered: 20/10/03
Posts: 807
I don't have a public Geeklog site, so I don't have a place to paste an example at the moment. Could you link to the story you tried this in? I'd like to see its HTML.
 Quote

Status: offline

samstone

Forum User
Full Member
Registered: 29/09/02
Posts: 820
I have used this with one of my stories. But I didn't use the thumbnail image from the gallery because the gallery thumbmail is not small enough. I put a small headshot of the author and link it to a large picture in the gallery.

I also have HTMLArea, which make this much easier to upload the thumbnail picture and link it to the gallery. I think it is faster and less troublesome than the other way.

Sam
 Quote

Status: offline

ola_one

Forum User
Full Member
Registered: 28/06/03
Posts: 186
Hello guys, somehow I tried the code and all I got was an error.

The following errors occured while trying to save your story. Please correct these errors before saving
image #1, 20040111190152134_1.jpg, was not used. You must include this image in the intro or body before you can save your changes

In writing my story, I had included the tag as you said:


I also browsed to the image and added this image to the story as the only image picked, leaving the other 4 areas blank.

But when I saved the story, I got the error message.

Did I miss something in the tag or what did I do wrong?

Thanks

Ola
 Quote

Status: offline

samstone

Forum User
Full Member
Registered: 29/09/02
Posts: 820
Which tag are you talking about?

In your case you should not be using Turias tag. You should be using [image1] at the place where you want the image to be.

If you use Turias tag. You should not be uploading anything from those fields.

Sam
 Quote

Status: offline

Turias

Forum User
Full Member
Registered: 20/10/03
Posts: 807
Yeah, don't actually attach the image.
 Quote

Status: offline

ola_one

Forum User
Full Member
Registered: 28/06/03
Posts: 186
Okay guys,

Now the only other question is do I write Turias code verbatim, in other words, am I to include the [ ] and | in the tag?

The way Turias wrote the tag


PHP Formatted Code
<a href="[www.abc.com/gallery/family]"><img src="[www.abc.com/gallery/family/boy]" align="left|..." /></a>

 


Would the above code work or should the ... not be in it?

Thanks a million.

Ola
 Quote

Status: offline

Turias

Forum User
Full Member
Registered: 20/10/03
Posts: 807
No.

Can you just post a link to the image and I can show you an example?
 Quote

Status: offline

ola_one

Forum User
Full Member
Registered: 28/06/03
Posts: 186
The following are the two links

Link to the Album:
http://www.feyiola.com/gallery/summer2003

Link to the thumbnail:

http://www.feyiola.com/gallery/summer2003/Orlando_Vacation_004

Thanks

Ola
 Quote

Page navigation

All times are EDT. The time is now 07:00 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content