Welcome to Geeklog Tuesday, May 11 2021 @ 12:55 am EDT

Geeklog Forums

Forum 2.2


Zippo

Anonymous
I get this error message when trying to install the forum

Install/Uninstall Plugin
Installation Failed -- See your error log to find out why.

The Plugin is Not Installed


And in error.log it is like this;

Tue Dec 23 14:37:33 2003 - Attempting to install the forum Plugin
Tue Dec 23 14:37:33 2003 - executing CREATE TABLE gl_forum_categories (
cat_order smallint(4) NOT NULL default '0',
cat_name varchar(255) NOT NULL default '',
cat_dscp text NOT NULL,
id int(2) NOT NULL auto_increment,
PRIMARY KEY (id)
) TYPE=MyISAM;
Tue Dec 23 14:37:33 2003 - executing CREATE TABLE gl_forum_forums (
forum_order int(4) NOT NULL default '0',
forum_name varchar(255) NOT NULL default '0',
forum_dscp text NOT NULL,
forum_id int(4) NOT NULL auto_increment,
forum_cat int(3) NOT NULL default '0',
grp_id mediumint(8) NOT NULL default '2',
PRIMARY KEY (forum_id),
KEY forum_cat (forum_cat),
KEY forum_id (forum_id)
) TYPE=MyISAM;
Tue Dec 23 14:37:33 2003 - executing CREATE TABLE gl_forum_topic (
id mediumint(8) NOT NULL auto_increment,
pid mediumint(8) NOT NULL default '0',
uid mediumint(8) NOT NULL default '0',
name varchar(50) default NULL,
date varchar(12) default NULL,
lastupdated varchar(12) default NULL,
email varchar(50) default NULL,
website varchar(100) NOT NULL default '',
subject varchar(100) NOT NULL default '',
comment longtext,
postmode varchar(10) NOT NULL default '',
replies bigint(10) NOT NULL default '0',
views bigint(10) NOT NULL default '0',
ip varchar(255) default NULL,
mood varchar(100) default 'indifferent',
sticky tinyint(1) NOT NULL default '0',
moved tinyint(1) NOT NULL default '0',
locked tinyint(1) NOT NULL default '0',
forum int(3) NOT NULL default '0',
PRIMARY KEY (id),
KEY forum_idx (forum)
) TYPE=MyISAM;
Tue Dec 23 14:37:33 2003 - executing CREATE TABLE gl_forum_log (
uid mediumint(8) NOT NULL default '0',
forum mediumint(3) NOT NULL default '0',
topic mediumint(3) NOT NULL default '0',
time varchar(40) NOT NULL default '0',
KEY uid_forum (uid,forum),
KEY uid_topic (uid,topic),
KEY forum (forum)
) TYPE=MyISAM;
Tue Dec 23 14:37:33 2003 - executing CREATE TABLE gl_forum_moderators (
mod_id int(11) NOT NULL auto_increment,
mod_username varchar(30) default NULL,
mod_forum varchar(30) default NULL,
mod_delete tinyint(1) NOT NULL default '0',
mod_ban tinyint(1) NOT NULL default '0',
mod_edit tinyint(1) NOT NULL default '0',
mod_move tinyint(1) NOT NULL default '0',
mod_stick tinyint(1) NOT NULL default '0',
PRIMARY KEY (mod_id)
) TYPE=MyISAM;
Tue Dec 23 14:37:33 2003 - executing CREATE TABLE gl_forum_settings (
slogan varchar(255) NOT NULL default '',
registrationrequired tinyint(1) unsigned NOT NULL default '0',
registerpost tinyint(1) unsigned NOT NULL default '0',
allowhtml tinyint(1) unsigned NOT NULL default '1',
glfilter tinyint(1) unsigned NOT NULL default '0',
censor tinyint(1) unsigned NOT NULL default '1',
showmood tinyint(1) unsigned NOT NULL default '1',
allowsmilies tinyint(1) unsigned NOT NULL default '1',
allowavatar tinyint(1) unsigned NOT NULL default '1',
allow_notify tinyint(1) unsigned NOT NULL default '1',
showiframe tinyint(1) unsigned NOT NULL default '1',
msgauto tinyint(1) NOT NULL default '1',
xtrausersettings tinyint(1) unsigned NOT NULL default '0',
img_width int(4) NOT NULL default '50',
viewtopicnumchars int(4) NOT NULL default '20',
topicsperpage int(4) NOT NULL default '10',
postsperpage int(4) NOT NULL default '10',
imgset varchar(30) NOT NULL default '',
cb_enable tinyint(1) NOT NULL default '0',
cb_homepage tinyint(1) NOT NULL default '0',
cb_where tinyint(1) NOT NULL default '0',
level1 int(5) NOT NULL default '1',
level2 int(5) NOT NULL default '15',
level3 int(5) NOT NULL default '35',
level4 int(5) NOT NULL default '70',
level5 int(5) NOT NULL default '120',
level1name varchar(40) NOT NULL default 'Newbie',
level2name varchar(40) NOT NULL default 'Junior',
level3name varchar(40) NOT NULL default 'Chatty',
level4name varchar(40) NOT NULL default 'Regular Member',
level5name varchar(40) NOT NULL default 'Active Member'
) TYPE=MyISAM;
Tue Dec 23 14:37:33 2003 - executing CREATE TABLE gl_forum_userprefs (
uid mediumint(8) NOT NULL default '0',
topicsperpage int(3) NOT NULL default '5',
postsperpage int(3) NOT NULL default '5',
popularlimit int(3) NOT NULL default '10',
messagesperpage int(3) NOT NULL default '20',
searchlines int(3) NOT NULL default '20',
viewanonposts tinyint(1) NOT NULL default '1',
alwaysnotify tinyint(1) NOT NULL default '0',
membersperpage int(3) NOT NULL default '20',
showiframe tinyint(1) NOT NULL default '1',
PRIMARY KEY (uid)
) TYPE=MyISAM;
Tue Dec 23 14:37:33 2003 - executing CREATE TABLE gl_forum_watch (
id mediumint(8) NOT NULL auto_increment,
forum_id mediumint(8) NOT NULL default '0',
topic_id mediumint(8) NOT NULL default '0',
uid mediumint(8) NOT NULL default '0',
date_added date NOT NULL default '0000-00-00',
PRIMARY KEY (id),
KEY uid (uid),
KEY forum_id (forum_id),
KEY topic_id (topic_id)
) TYPE=MyISAM;
Tue Dec 23 14:37:33 2003 - executing CREATE TABLE gl_forum_banned_ip (
host_ip varchar(255) default NULL,
KEY index1 (host_ip)
) TYPE=MyISAM;
Tue Dec 23 14:37:33 2003 - executing CREATE TABLE gl_forum_userinfo (
`uid` mediumint(8) NOT NULL default '0',
`location` varchar(128) NOT NULL default '',
`aim` varchar(128) NOT NULL default '',
`icq` varchar(128) NOT NULL default '',
`yim` varchar(128) NOT NULL default '',
`msnm` varchar(128) NOT NULL default '',
`interests` varchar(255) NOT NULL default '',
`occupation` varchar(255) NOT NULL default '',
PRIMARY KEY (`uid`)
) TYPE=MyISAM COMMENT='Forum Extra User Profile Information';
Tue Dec 23 14:37:33 2003 - Success - Created table
Tue Dec 23 14:37:33 2003 - Inserting default data into gf_settings table
Tue Dec 23 14:37:33 2003 - 1136: Column count doesn't match value count at row 1. SQL in question:
Tue Dec 23 14:37:33 2003 - Error inserting default data into gf_settings table
Tue Dec 23 14:37:33 2003 - Attempting to unregister the Forum plugin from Geeklog
Tue Dec 23 14:37:33 2003 - Removing Table gl_forum_topic
Tue Dec 23 14:37:33 2003 - Removing Table gl_forum_categories
Tue Dec 23 14:37:33 2003 - Removing Table gl_forum_forums
Tue Dec 23 14:37:33 2003 - Removing Table gl_forum_settings
Tue Dec 23 14:37:33 2003 - Removing Table gl_forum_watch
Tue Dec 23 14:37:33 2003 - Removing Table gl_forum_moderators
Tue Dec 23 14:37:33 2003 - Removing Table gl_forum_banned_ip
Tue Dec 23 14:37:33 2003 - Removing Table gl_forum_log
Tue Dec 23 14:37:33 2003 - Removing Table gl_forum_userprefs
Tue Dec 23 14:37:33 2003 - Removing Table gl_forum_userinfo
Tue Dec 23 14:37:33 2003 - Removing forum Admin Group
Tue Dec 23 14:37:33 2003 - Removing root users from admin of forum
Tue Dec 23 14:37:33 2003 - Removing forum.edit feature and rights to it
Tue Dec 23 14:37:33 2003 - DELETE FROM gl_access WHERE acc_ft_id =
Tue Dec 23 14:37:33 2003 - Removing forum.user feature and rights to it
Tue Dec 23 14:37:33 2003 - DELETE FROM gl_access WHERE acc_ft_id =
Tue Dec 23 14:37:33 2003 - Removing Forum - Block Definition
Tue Dec 23 14:37:33 2003 - ...success



Please help me
 Quote

vegeta9870

Anonymous
vegetIt means you previously had it installed. Just install it again, as you can see here:

Tue Dec 23 14:37:33 2003 - Removing Table gl_forum_topic
Tue Dec 23 14:37:33 2003 - Removing Table gl_forum_categories
Tue Dec 23 14:37:33 2003 - Removing Table gl_forum_forums
Tue Dec 23 14:37:33 2003 - Removing Table gl_forum_settings
Tue Dec 23 14:37:33 2003 - Removing Table gl_forum_watch
Tue Dec 23 14:37:33 2003 - Removing Table gl_forum_moderators
Tue Dec 23 14:37:33 2003 - Removing Table gl_forum_banned_ip
Tue Dec 23 14:37:33 2003 - Removing Table gl_forum_log
Tue Dec 23 14:37:33 2003 - Removing Table gl_forum_userprefs
Tue Dec 23 14:37:33 2003 - Removing Table gl_forum_userinfo
Tue Dec 23 14:37:33 2003 - Removing forum Admin Group
Tue Dec 23 14:37:33 2003 - Removing root users from admin of forum
Tue Dec 23 14:37:33 2003 - Removing forum.edit feature and rights to it
Tue Dec 23 14:37:33 2003 - DELETE FROM gl_access WHERE acc_ft_id =
Tue Dec 23 14:37:33 2003 - Removing forum.user feature and rights to it
Tue Dec 23 14:37:33 2003 - DELETE FROM gl_access WHERE acc_ft_id =
Tue Dec 23 14:37:33 2003 - Removing Forum - Block Definition
Tue Dec 23 14:37:33 2003 - ...success


It deleted the tables pertaining to the forum, if you install it again, it will work.
 Quote

deesh123

Anonymous
How about this instal problem:
PHP Formatted Code
Sun Dec  4 10:25:48 2005 - 1054: Unknown column 'cb_enable' in 'field list'. SQL in question: SELECT cb_enable, cb_homepage, cb_where FROM gl_forum_settings
Sun Dec  4 10:28:02 2005 - 1054: Unknown column 'cb_enable' in 'field list'. SQL in question: UPDATE gl_forum_settings SET
        slogan='Forum Index',
        registrationrequired='0',
        registerpost='1',
        allowhtml='1',
        glfilter='0',
        censor='1',
        showmood='1',
        allowsmilies='1',
        allow_notify='1',
        showiframe='1',
        msgauto='1',
        xtrausersettings='0',
        img_width='50',
        viewtopicnumchars='20',
        topicsperpage='10',
        postsperpage='10',
        level1='1',
        level2='15',
        level3='35',
        level4='70',
        level5='120',
        level1name='Newbie',
        level2name='Junior',
        level3name='Chatty',
        level4name='Regular Poster',
        level5name='Full Member',
        cb_enable='1',
        cb_homepage='0',
        cb_where='1'
     
Sun Dec  4 10:28:28 2005 - 1054: Unknown column 'cb_enable' in 'field list'. SQL in question: SELECT cb_enable, cb_homepage, cb_where FROM gl_forum_settings
 


Any guesses what I did wroong?
 Quote

deesh123

Anonymous
Before I posted the last message I didn't run the upgrade install php for the forum.

However, I still got an error after running it:

PHP Formatted Code
Sun Dec  4 10:51:48 2005 - Geeklog Forum Project Plugin Upgrade initiated
Sun Dec  4 10:51:48 2005 - Begin processing /home/content/d/e/e/deesh123/html/plugins/forum/sql/updates/mysql_1.0_to_2.0.php
Record Count is:26
Sun Dec  4 10:51:48 2005 - executing Delete from gl_forum_log
Sun Dec  4 10:51:48 2005 - executing ALTER TABLE gl_forum_topic ADD moved tinyint(1) DEFAULT '0' NOT NULL AFTER sticky
Sun Dec  4 10:51:48 2005 - 1060: Duplicate column name 'moved'. SQL in question: ALTER TABLE gl_forum_topic ADD moved tinyint(1) DEFAULT '0' NOT NULL AFTER sticky
Sun Dec  4 11:04:32 2005 - 1054: Unknown column 'cb_enable' in 'field list'. SQL in question: SELECT cb_enable, cb_homepage, cb_where FROM gl_forum_settings
Sun Dec  4 11:11:51 2005 - Geeklog Forum Project Plugin Upgrade initiated
Sun Dec  4 11:11:51 2005 - Begin processing /home/content/d/e/e/deesh123/html/plugins/forum/sql/updates/mysql_1.0_to_2.0.php
Record Count is:26
Sun Dec  4 11:11:51 2005 - executing Delete from gl_forum_log
Sun Dec  4 11:11:51 2005 - executing ALTER TABLE gl_forum_topic ADD moved tinyint(1) DEFAULT '0' NOT NULL AFTER sticky
Sun Dec  4 11:11:51 2005 - 1060: Duplicate column name 'moved'. SQL in question: ALTER TABLE gl_forum_topic ADD moved tinyint(1) DEFAULT '0' NOT NULL AFTER sticky
 
 Quote

deesh123

Anonymous
I figured it out... I didn't install the correct update .php. I should have updated from 2.0 to 2.2. Doh! - that was a mistake

Hope this helps anyone who searches for this topic in the future
 Quote

All times are EDT. The time is now 12:55 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content