Welcome to Geeklog, Anonymous Thursday, December 08 2022 @ 08:48 pm EST

Geeklog Forums

No control over Admin / passord

Page navigation


Tocotoco

Anonymous
happy
It is runing for the first time and is looking good ! the "check" utility did a great job. Now to my problem: 1. Can't change passwords ..2..Can't do anything at Adimin. I see a small screen flash by only to land back to the main screen.
Please help. hey!, sorry if the answer to this is somewhere, I tried to find it unsuccesfully, sorry, please see if you can help, it is appreciated.
Thank you,
Toco
 Quote

TocoToco

Anonymous
Found it! found the answer in this very Forum. Extensive and detailed. Sorry again. Will see if I can manage. Laughing Out Loud
 Quote

Tocotoco

Anonymous
I worked ! I got in there but, still could not change the password from default settings ...
 Quote

Tocotoco

Anonymous
This does not apply, I had another PHP program running before...


Make sure you have register_globals=on in your php.ini. And don't forget to restart your webserver when you change that setting.

The default for this setting is off as of PHP 4.2.0, so you may also run into this problem when you upgrade to a more recent version of PHP.
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Quote by Tocotoco: This does not apply, I had another PHP program running before...

That doesn't mean anything, as that other PHP script may have been written such that it works with register_globals being off.

Please check your register_globals setting instead of assuming things.

bye, Dirk
 Quote

Tocotoco

Anonymous
Now, it appears that since I managed to login to "admin" with the generic password, I can´t log out. Also, when I start the browser, pointed at http://domain/index.php, I am sent to " http://domain/index.php?msg=8 " which is the admin page.
I am awaiting repply from server owner about php.ini settings. Meanwhile, is there any other file within the program that might be worth looking at for corruption/repair?
Thank you
Toco
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Quote by Tocotoco: I am sent to " http://domain/index.php?msg=8 " which is the admin page.

That's wrong then. All the admin pages should be in the "admin" directory. The index.php in the root of your domain is the one that displays Geeklog's standard front page, while the index.php in the admin directory is simply a redirect to admin/moderation.php.

Sounds like you mixed the files from the admin and public_html directories. I'd suggest you upload them again.

Quote by Tocotoco: I am awaiting repply from server owner about php.ini settings.

http://yourdomain/admin/install/info.php should give you an overview of PHP's settings, one of which is register_globals.

To me, it sounds like you tried so many things that your install is now pretty much messed up. You may want to start over from the beginning ...

bye, Dirk
 Quote

Tocotoco

Anonymous
Thank you for your reply Dirk. It might be so. I wil re-load everything. I will still try and keep away from having both HTTPDOCS and PUBLIC_HTNL . should I do the changes while I have the files on my pc? or should I not do any changes at all?
Toco
 Quote

Tocotoco

Anonymous
Info.ph has only 1kb, no info. You should know that the first tar folder had 1kb on the config.php file. I will download another tar file folder.
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Quote by Tocotoco: Info.ph has only 1kb, no info.

That's correct. It's a tiny PHP script (a one-liner, actually) which, when executed, will display all the information about the PHP settings on your webserver.

bye, Dirk
 Quote

Tocotoco

Anonymous
Thank you on the *.php question. One final request: I am now past the success screen, into the home screen and when tryed to log in to admin I got the "line 90 on the config.php file error" thsi tells me that the ADMIN pointer is wrong and I have
$_CONF['site_admin_url'] = '/home/httpd/vhosts/domain.com/httpdocs/admin';
which is the right path, perhaps I should go URL like
http://domain.com/admin
please anyone help me on this..
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Yes, 'site_admin_url' should be a URL, not a path (obviously, all variables ending in "_path" should be paths and variables ending in "_url" should be URLs).

The default setting for that variable is
Text Formatted Code
$_CONF['site_admin_url']    = $_CONF['site_url'] . '/admin';
 
and in most cases, it should work just fine if you leave it at that.

bye, Dirk
 Quote

Tocotoco

Anonymous
even tho my path is
/home/httpd/vhosts/domain.com/httpdocs/admin
when I use your defaul, I get:
Parse error: parse error in /home/httpd/vhosts/homeya.com/httpdocs/config.php on line 90

Warning: main(classes/timer.class.php): failed to open stream: No such file or directory in /home/httpd/vhosts/homeya.com/httpdocs/lib-common.php on line 105

Fatal error: main(): Failed opening required 'classes/timer.class.php' (include_path='.:/usr/share/pear') in /home/httpd/vhosts/homeya.com/httpdocs/lib-common.php on line 105
Can any one tell me how to do this URL as per above true path, properly please. (sorry, basic question, I know)
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
When you get a parse error it means that there is a syntax error somewhere (in your case: in the config.php). It has nothing to do with whether your paths are wrong or right.

Line 90 in the original config.php is the one just after the $_CONF['site_admin_url'], so chances are you forgot a single quote or a semicolon there.

Can any one tell me how to do this URL as per above true path, properly please.

Okay, let's try it another way: When you drop a simple HTML file, say "hello.html", into your httpdocs directory, then you can call it up by entering "http://yourdomain/hello.html" in your browser, right? If so, then you should have Geeklog's index.php, lib-common.php, etc., as well as the admin directory inside your httpdocs. Then http://yourdomain/admin/moderation.php would be the correct URL to the Admin's moderation page. Which means that the default setting for $_CONF['site_admin_url'], which I already quoted above, would be the correct choice for your site.

Also, I just realised you seem to have the config.php inside the httpdocs directory. It shouldn't be there, as that means it's accessible from a URL - and you really don't want that.

config.php, the system directory, and everything else that was not in Geeklog's public_html should be outside of your httpdocs directory, i.e. in /home/httpd/vhosts/domain.com

Or, to put it another way: Imagine that "public_html" was really named "httpdocs". So everything that's inside "public_html" should go inside your httpdocs directory (keeping all the folders), and what's outside of public_html should also be outside of httpdocs on your server.

Hope that helps (and yes, I know: "By making something absolutely clear, somebody will be confused" ...).

bye, Dirk
 Quote

Tocotoco

Anonymous
Dirk: thank you for the security advise. My question is this: By me mreging the public_html files into httpdocs , do I create any broken connections inside the program?. I just could not find the proper string to point to the ADMIN URL in the config.php file, and that is extrange. Your defaul did not work also string on the config.php file. As I preapare to upload the files again, I can't help but wonder why you made a separate directory for the public files and not just a separate directory for the private ones, is it because most people would have public_html instead of httpdocs?. All I want, is to avoid redundancy by having two public directories...Don't try to level down with me, I am new and I respect you for what you know about this great program. Should I not get it to work like this, I am going to try again using your default tree, with public_html included.
 Quote

Tocotoco

Anonymous
OK now I am up and running but up until the login problem. First I get the proper start up page ander http://doamin.com including the info about the default password... then I log into Admin using it ... I get in, but when I tray to change anything I can't. So I looked at info.php and shows a path to php.ini I don't have access to. Until I get the reply by the server owner, I guess I am done. Unless I am missing something inside the admin screen, how do you change the password? Or would it have to do with settings somewhere?
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
You can change your password from the "Account Information" page, as linked from the "User Functions" block.

And did you check the settings for register_globals on the info.php output? It's somewhere in that long list.

bye, Dirk
 Quote

Tocotoco

Anonymous
Dirk
I must say that the process has been painful, but nontheless very useful as a learning curve, I am now sure I will install Geeklog on my other domain as well. I got the server people to change the settings, not without momblings, here is what he said by ICQ
not by default (=on settings on php.ini )

Register Globals is a bad way to program and they all know that but some scripts still insist on using it even thought the entire php comunity has said DONT USE register_globals=on

So servers and accounts dont come set to on mode
Since I am sure this is in people's minds by now, I thougt I give to the chance to respond
 Quote

Tocotoco

Anonymous
Dirk
1. Settings have been changed on php.ini to "on"
2. On hhttp://domain.com I get the proper initial screen. I log into Admin account fine but, if I click on account information, I get to stay in the same screen.
Please tell me how to trouble dhoot this one.
 Quote

Tocotoco

Anonymous
Dirk
1. Settings have been changed on php.ini to "on"
2. On hhttp://domain.com I get the proper initial screen. I log into Admin account fine but, if I click on account information, I get to stay in the same screen.
Please tell me how to trouble dhoot this one.
 Quote

Page navigation

All times are EST. The time is now 08:48 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content