Topics

User Functions

Events

There are no upcoming events

What's New

Stories last 2 weeks

No new stories

Comments last 2 weeks

No new comments

Trackbacks last 2 weeks

No new trackback comments

Links last 2 weeks

No recent new links

Downloads last 2 weeks

No new files

Welcome to Geeklog Tuesday, December 06 2016 @ 07:05 am EST

 Forum Index > Support > Installation Support New Topic Post Reply
 Warning: open_basedir restriction in effect
First | Previous | 1 2| Next | Last
Prev Topic Next Topic
   
Anonymous: Patrick
 19/12/2003 11:44am (Read 50474 times)  
Can someone help me with the error below?

Warning: open_basedir restriction in effect. File is in wrong directory in /home/httpd/vhosts/casinoceo.com/httpdocs/admin/install/install.php on line 513

Fatal error: Failed opening required '/home/httpd/vhosts/casinoceo.com/system/classes/template.class.php' (include_path='.:/usr/share/pear') in /home/httpd/vhosts/casinoceo.com/httpdocs/admin/install/install.php on line 513
 
 Quote
Dirk
 19/12/2003 02:37pm  

Admin

Status: offline
Site Admin

Registered: 12/01/2002
Posts: 13073
Location:Stuttgart, Germany
Hmm, assuming you entered /home/httpd/vhosts/casinoceo.com/ as your "path to Geeklog", I can't see anything obviously wrong.

Geeklog usually works with the open_basedir restrictions in effect, as long as you've got your paths right.

Is it possible that your hosting service does not allow you to have files outside of the "httpdocs" directory?

bye, Dirk
 
Profile Email Website
 Quote
Anonymous: g7pkf
 31/12/2003 11:42am  
same error here did you ever solve it? all my paths look a okay???

e-smith

Warning: open_basedir restriction in effect. File is in wrong directory in /home/e-smith/files/ibays/Primary/html/admin/install/install.php on line 513

Fatal error: Failed opening required '/opt/geeklog-1.3.8-1sr3/system/classes/template.class.php' (include_path='.:/usr/share/php') in /home/e-smith/files/ibays/Primary/html/admin/install/install.php on line 513
 
 Quote
Anonymous: g7pkf
 01/01/2004 05:12am  
reinstalled geeklog, still no joy-even put into seperate directory as i suspected cgi-bin, why does it have the bit
(include_path='.:/usr/share/php') in the error there is nothing at this location?

Warning: open_basedir restriction in effect. File is in wrong directory in /home/e-smith/files/ibays/geeklog/html/admin/install/install.php on line 513

Fatal error: Failed opening required '/opt/geeklog-1.3.8-1sr3/system/classes/template.class.php' (include_path='.:/usr/share/php') in /home/e-smith/files/ibays/geeklog/html/admin/install/install.php on line 513
 
 Quote
Dirk
 01/01/2004 05:28am  

Admin

Status: offline
Site Admin

Registered: 12/01/2002
Posts: 13073
Location:Stuttgart, Germany
It looks like you entered "/opt/geeklog-1.3.8-1sr3" as your "path to Geeklog". Is that the correct path?

It looks like your webserver (or rather the open_basedir restriction in PHP) doesn't like that path, so you'll either have to put the files somewhere else of maybe there is another path to the same directory (e.g. through a symlink). I would assume that your webserver is configured such that it would prefer to have all files below /home/e-smith.

The "(include_path='.:/usr/share/php')" bit is only PHP telling you where else it looked for the file.

bye, Dirk
 
Profile Email Website
 Quote
Anonymous: g7pkf
 01/01/2004 07:15am  
that worked cheers,
 
 Quote
Anonymous: Robert
 03/01/2004 10:25pm  
I got much the same error message.....

Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(/var/www/domains/config.php) is not within the allowed path(s): (/var/www/domains/rmdesign.com/) in /var/www/domains/rmdesign.com/myadminwas/install/install.php on line 80

The "public_html" folder is named "www" I am beginning to understand this must be a 'sym link' but I am still confused as to how to specify to a folder that is above. Obviously it isn't /var/www/domains/rmdesign.com/www/

So even after rtfm, this bbs and google, I still don't know how to point outside of the public space, which means both config.php and lib-common.php preferences are wrong. Hopefully that explains the error message above.

If having files outside there isnt allowed by the hosting co., is it acceptable from a security standpoint to move all geeklog files to within the public area, but then use htaccess to protect them? Any advice appreciated. thanks.
 
 Quote
Dirk
 04/01/2004 04:40am  

Admin

Status: offline
Site Admin

Registered: 12/01/2002
Posts: 13073
Location:Stuttgart, Germany
Quote by Robert: The "public_html" folder is named "www" I am beginning to understand this must be a 'sym link'

No need for a symlink. Usually, simply copying everything from Geeklog's public_html folder into your www directory and changing $_CONF['path_html'] to read
PHP Formatted Code
$_CONF['path_html'] = $_CONF['path'] . 'www/';
 
should have the desired effect.

Quote by Robert: If having files outside there isnt allowed by the hosting co., is it acceptable from a security standpoint to move all geeklog files to within the public area, but then use htaccess to protect them? Any advice appreciated. thanks.

Having the files outside of the document root is always the better solution. For example, my hosting service accidentally disabled .htaccess files once, in which case such a directory would be world-readable again. Under normal circumstances, it should be safe, though.

bye, Dirk
 
Profile Email Website
 Quote
Anonymous: Grotesnor
 16/01/2004 07:05am  
I am having similar problems. The error message:

Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(/home/httpd/vhosts/mysite.com/config.php) is not within the allowed path(s): (/home/httpd/vhosts/mysite.com/httpdocs) in /home/httpd/vhosts/mysite.com/httpdocs/admin/install/install.php on line 80

My public_html folder is 'httpdocs' and this is where I placed all the geeklog public_html files. Changing $_CONF['path_html'] to $_CONF['path'] . 'httpdocs/'; didn't do anything. I am lost here. Any advice?
 
 Quote
Grotesnor
 16/01/2004 07:36am  

Newbie

Status: offline
Forum User

Registered: 15/01/2004
Posts: 4
To add to my previous posting, my config.php is in a folder 'geekfiles' below 'httpdocs' because my provider doesn't allow me to create folders above it. I have tried different paths in config.php and lib-common.php but with no result sofar. These path issues are getting pretty confusing now.
 
Profile Email
 Quote
Dirk
 16/01/2004 08:07am  

Admin

Status: offline
Site Admin

Registered: 12/01/2002
Posts: 13073
Location:Stuttgart, Germany
Going by the error messages and the way you describe things, it looks like you should have
PHP Formatted Code
$_CONF['path'] = '/home/httpd/vhosts/mysite.com/httpdocs/geekfiles/';

$_CONF['path_html'] = '/home/httpd/vhosts/mysite.com/httpdocs/';
 

I.e. in this case, it's better to set the path_html variable as an absolute path directly.

bye, Dirk
 
Profile Email Website
 Quote
Grotesnor
 16/01/2004 09:34am  

Newbie

Status: offline
Forum User

Registered: 15/01/2004
Posts: 4
Thanks for your quick reply. But unfortunately I haven't had any succes. I have tried different paths, in fact, I think I have tried every possible combination. I'm beginning to think my provider doesn't allow me to use paths in this way.

I'm confused as to which path the error message refers to. I've changed the path in lib-common.php and in config.php as well.
 
Profile Email
 Quote
Dirk
 16/01/2004 09:55am  

Admin

Status: offline
Site Admin

Registered: 12/01/2002
Posts: 13073
Location:Stuttgart, Germany
When you call up the install script (without doing anything) it will display a "hint" at the bottom of the page. Can you quote what it says there?

The error message you quoted above makes it pretty clear that the server is set up such that it expects everything to be below /home/httpd/vhosts/mysite.com/httpdocs, so if both the path and path_html variables start with this path, you should be fine.

bye, Dirk
 
Profile Email Website
 Quote
Grotesnor
 16/01/2004 11:09am  

Newbie

Status: offline
Forum User

Registered: 15/01/2004
Posts: 4
The hint at the bottom of the page is:
/home/httpd/vhosts/mysite.com/httpdocs/admin/install/install.php.
The paths in my config.php and lib-common.php are respectively:
$_CONF['path'] = '/home/httpd/vhosts/mysite.com/httpdocs/geekfiles/'; (where my config.php file resides),
$_CONF['path_html'] = $_CONF['path'] . '/home/httpd/vhosts/mysite.com/httpdocs/'; (where my public_html files are) and
require_once( '/home/httpd/vhosts/mysite.com/httpdocs/geekfiles/config.php' );
 
Profile Email
 Quote
Dirk
 16/01/2004 01:54pm  

Admin

Status: offline
Site Admin

Registered: 12/01/2002
Posts: 13073
Location:Stuttgart, Germany
Your $_CONF['path'] looks fine, but you should leave out the $_CONF['path'] when setting the $_CONF['path_html'] (see my other post above).

bye, Dirk
 
Profile Email Website
 Quote
Grotesnor
 16/01/2004 06:55pm  

Newbie


Status: offline
Forum User

Registered: 15/01/2004
Posts: 4
You were right, my mistake. But I still get the same result. I'm almost ready to give up. Maybe this just isn't going to work. Thanks for your time anyway.
 
Profile Email
 Quote
Dirk
 17/01/2004 04:19am  

Admin

Status: offline
Site Admin

Registered: 12/01/2002
Posts: 13073
Location:Stuttgart, Germany
Quote by Grotesnor: But I still get the same result. I'm almost ready to give up. Maybe this just isn't going to work.

Hmm, that would be the first time that someone did not get Geeklog to work with open_basedir restrictions in effect. So I'd like to know why it doesn't work.

Have you tried contacting your hosting service? I'd send them the error message you get and ask them what a valid path should look like.

bye, Dirk
 
Profile Email Website
 Quote
vadertech
 05/02/2004 04:21pm  

Full Member

Status: offline
Forum User

Registered: 26/05/2003
Posts: 329
nevermind

GeekLog Hosting, Installations and Upgrades - WWW.AWEHOST.COM - Hosting starts @ only $4.95/mo.
 
Profile Email Website
 Quote
Anonymous: Mitch
 11/02/2004 04:52pm  
PHP Formatted Code
Warning: open_basedir restriction in effect. File is in wrong directory in /home/httpd/vhosts/mydomain.com/httpdocs/admin/install/install.php on line 513

Fatal error: Failed opening required '/home/httpd/vhosts/mydomain.com/system/classes/template.class.php' (include_path='.:/usr/share/pear:/php/includes:/usr/share/php') in /home/httpd/vhosts/mydomain.com/httpdocs/admin/install/install.php on line 513
 


I am having the same issue and am really confused... I have been trying to install Geeklog for hours now. Please offer some advice!
 
 Quote
Dirk
 11/02/2004 05:10pm  

Admin

Status: offline
Site Admin

Registered: 12/01/2002
Posts: 13073
Location:Stuttgart, Germany
It looks like your hosting service doesn't want you to have files in the /home/httpd/vhosts/mydomain.com directory.

Often when open_basedir restrictions are in effect, it tells you where you are allowed to put files (as in the case of the poster above). However, in your case it doesn't do that, so I'd suggest asking your hosting service for advice.

If all else fails, you could put the files that normally reside outside of public_html into a password-protected folder inside of public_html, but the way you tried it is the preferred one.

bye, Dirk
 
Profile Email Website
 Quote
First | Previous | 1 2| Next | Last
Content generated in: 4.97 seconds New Topic Post Reply
 All times are EST. The time is now 07:05 am.
Normal Topic Normal Topic
Sticky Topic Sticky Topic
Locked Topic Locked Topic
New Post New Post
Sticky Topic W/ New Post Sticky Topic W/ New Post
Locked Topic W/ New Post Locked Topic W/ New Post
View Anonymous Posts 
Able to post 
Filtered HTML Allowed 
Censored Content