Welcome to Geeklog Saturday, September 26 2020 @ 05:06 pm EDT

Geeklog Forums

Upgrading from Geeklog 1.3.8rc2 to 1.3.8sr3 error


Mike Steder

Anonymous
confused
Hello all,

I'm currently trying to update my Geeklog from a release candidate version of 1.3.8 to the most recent version.

After setting everything up and going to upgrade my database I recieved the following error:

PHP Formatted Code
1060: Duplicate column name 'is_default'
 


This is especially weird because this occured on my first attempt to upgrade. I get the same error on previous attempts. I'm confused as to where I go from here to fix this.

any help would be greatly appreciated,

Mike
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
You don't need to update the database. All 1.3.8 versions from the Release Candidates up to the current version use the same database layout.

Database changes are usually indicated by a new version number, e.g. all 1.3.7 versions have the same layout, but it is different from the 1.3.8 versions.

bye, Dirk
 Quote

davidan

Anonymous
I ran into this same issue. After I got this error I noticed that my site seems to be working as normal.

However, my question is --- should I be worried about anything in the database after attempting to upgrade it?

I have a backup --- just trying to determine if I need to be paranoid or not ...


Thx

David
 Quote

Status: offline

DTrumbower

Forum User
Moderator
Registered: 08/01/03
Posts: 507
If you already had a 1.3.8 db, you will be fine.
 Quote

All times are EDT. The time is now 05:06 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content