Welcome to Geeklog, Anonymous Saturday, June 22 2024 @ 07:47 am EDT

Geeklog Forums

Can\'t moderate posts in Forum 2.2RC1


Status: offline

the_equivocator

Forum User
Newbie
Registered: 08/25/03
Posts: 5
I can\'t seem to moderate/delete/move any forum posts with my super administrator/privileges-up-the-wazoo account. I go to admin>forum>messages and click on moderate, and all it does is bring me to the post itself. (I get directed to /forum/viewtopic.php?&forum=3&showtopic=10). On that page, there doesn\'t seem to be any way to actually moderate the message. So, am I missing something? Did I do the install incorrectly? I am running a clean 2.2RC1 install over the newest version of geeklog. Thanks!
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
You need to assign moderators for the forums before you can moderate (even if you\'re logged in as the Geeklog Admin user). bye, Dirk
 Quote

Status: offline

the_equivocator

Forum User
Newbie
Registered: 08/25/03
Posts: 5
Oops, sorry. I originally said this but the forum ate my post because I forget the subject field the first time. But, the user I am logged in as is considered a Moderator for every forum (I am using the user that created each forum, so it was automatically made a moderator).
 Quote

Status: offline

the_equivocator

Forum User
Newbie
Registered: 08/25/03
Posts: 5
Oh, nevermind, I figured it out. I changed my login name between the forum install and now, and while everything else automatically updated this, the forum moderation section did not (maybe because the forum uses user_name instead of user_id as far as moderation is concerned?). Anyway, it\'s working as expected now. Again, many thanks, Dirk.
 Quote

t.bag

Anonymous
A different question though:

It seems that it is not possible to separate the moderating and administrating rights. A moderator must have the forum.user and forum.edit rights. But if he has the forum.edit right he has the full access to the forum plugin, i.e. not only the "messages" section where he can edit posts but also the "settings" and the "Board Admin" panels. I think these should be reserved to the Site Admin.

Or did I get something wrong?
 Quote

All times are EDT. The time is now 07:47 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content