Welcome to Geeklog, Anonymous Monday, January 30 2023 @ 09:37 am EST

Geeklog Forums

Error Messages On Install Script


Lyon Xile

Anonymous
I just ran the install script for the first time, clicked next on the opening page and I get these two error messages:

---
Parse error: parse error, unexpected T_STRING in /home3/xile/config.php on line 95

Fatal error: Failed opening required \'databases/.class.php\' (include_path=\'.:/usr/local/lib/php\'Wink in /home3/xile/system/lib-database.php on line
---

Any idea how to fix those?
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Quote by Lyon Xile:Any idea how to fix those?
Yes: http://www.geeklog.net/docs/install.html#parse-error bye, Dirk
 Quote

Lyon Xile

Anonymous
Alright well I fixed the parse error, but the other one still shows up.
 Quote

Lyon Xile

Anonymous
And yes I\'ve tried what they said in the install manual...and now I get a 404 Error from my host when I click next.
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Is that the only error you get now? If so, make sure you still have this line in config.php:
Text Formatted Code
$_DB_dbms = 'mysql';   // Do not change (currently, only MySQL is supported)
bye, Dirk
 Quote

Lyon XIle

Anonymous
Yes I see that line in config.php so it\'s there.
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Can you please quote all the error messages you\'re getting now? bye, Dirk
 Quote

Lyon Xile

Anonymous
This is the exact message which comes up when I click \'next\' on the opening page in the install script:

---
Fatal error: Failed opening required \'cgi-bin.spaceports.com/system/databases/mysql.class.php\' (include_path=\'.:/usr/local/lib/php\'Wink in /home3/xile/system/lib-database.php on line 110
---

Nothing else shows up but that message.
 Quote

Status: offline

DTrumbower

Forum User
Moderator
Registered: 01/08/03
Posts: 507
What are your paths in config.php?
 Quote

Lyon Xile

Anonymous
Alright well it\'s one problem after another...lol. I got onto the next page by fixing the paths in config.php as you suggested, but now I get these two messages after I click \'next\' on the following page: --- Warning: Access denied for user: \'xile@localhost\' (Using password: YES) in /home3/xile/system/databases/mysql.class.php on line 104 Warning: MySQL Connection Failed: Access denied for user: \'xile@localhost\' (Using password: YES) in /home3/xile/system/databases/mysql.class.php on line 104 Cannnot connect to DB server --- Pretty self explanatory, I just don\'t know where to change this password. The settings I entered in config.php are all OK as far as I can see.
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany

Lyon Xile

Anonymous
Alright I\'m pretty close to gettin this thing up...I clicked next and I now got this message: --- 1050: Table \'gl_access\' already exists --- And no indication to do anything else. Just a blank page with that on it.
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany

Status: offline

D1

Forum User
Chatty
Registered: 08/27/03
Posts: 55
Hello Everyone, I use Geeklog 1.3.8. Each time I try to send all my members a mail I receive the following error. Description: Unable to locate the server named \"admin\" --- the server does not have a DNS entry. Perhaps there is a misspelling in the server name, or the server no longer exists. Double-check the name and try again. And my address bar will display this. /admin/mail.php Can anyone tell me the file I need to alter to rectify this problem? Regards Question
What an old man can see, a young man will never see even though he is standing at the top of the highest mountain.
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Quote by D1:Unable to locate the server named \"admin\" --- the server does not have a DNS entry. Perhaps there is a misspelling in the server name, or the server no longer exists. Double-check the name and try again
Well, try to follow that advise. One of your users may have entered a wrong or invalid email address. E.g. something like \"name@admin\" - technically, that\'s a valid email address. But Geeklog can\'t possibly know if that address exists before it tries to send out the email ... bye, Dirk P.S. Please don\'t attach new questions to unrelated threads - start a new topic instead. Thanks.
 Quote

All times are EST. The time is now 09:37 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content