Welcome to Geeklog, Anonymous Sunday, July 21 2024 @ 07:16 am EDT

Geeklog Forums

SQL Error?? with Upgrade to 1.38


Status: offline

seshon

Forum User
Newbie
Registered: 03/27/03
Posts: 5
whats up guys.. I get this error not sure what it\'s asking. AND im not too sure if the upgrade had anything to do with it.. it happens when I want to view user profile. here\'s the error: 1064: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near \'WHERE gl_users.uid = 4 AND .uid = 4\' at line 1 I\'ve looked as much as I could for simular probelms but did\'nt find anything. If anyone can help me with this problem that would be great. thx seshon
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Can you quote the line with the full error message from Geeklog\'s error.log file, please? bye, Dirk
 Quote

seshon

Anonymous
caffeinated
heres the error log line in question: Sun Aug 3 16:19:21 2003 - 1064: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near \'WHERE gl_users.uid = 2 AND .uid = 2\' at line 1 SQL in question: SELECT * FROM gl_users, WHERE gl_users.uid = 2 AND .uid = 2 .. cunfuzzez me..
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Quote by seshon:SELECT * FROM gl_users, WHERE ...
There\'s a table name missing after the \',\' (and in front of the \'.uid\'). However, that doesn\'t look like some code from Geeklog. Do you have any plugins installed that may extend the user profile? The forum, for example? You may have forgotten to update that plugin (or hack) for 1.3.8. bye, Dirk
 Quote

Status: offline

seshon

Forum User
Newbie
Registered: 03/27/03
Posts: 5
Yes I did ad forum but the new 2.2 version for 1.38 was there something else I should have done?
 Quote

Status: offline

seshon

Forum User
Newbie
Registered: 03/27/03
Posts: 5
ive tried reinstalling forum didnt help - i have no clue on what to do..
 Quote

All times are EDT. The time is now 07:16 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content