Welcome to Geeklog, Anonymous Saturday, October 01 2022 @ 10:44 pm EDT

Geeklog Forums

Will this kinda installation work ???


Status: offline

xspace

Forum User
Regular Poster
Registered: 03/04/03
Posts: 100
stressed
Currently I host 1.3.7r1 locally on XP Pro, Apache, MySQL, and PHP. I want to install 1.3.8 but I do not want to have any downtime. Can I do this ?? 1. Create 1 more database 2. Install GL 1.3.8 on another directory under Apache2 htdocs 3. Cont to hack GL 1.3.8 til satisfactory, however still concurrently running the present GL 1.3.7. 4. Backup the GL 1.3.7 database and restore it into the GL 1.3.8 dbase once GL 1.3.8 is completed. Will this work ??? Am I also correct in saying that if I do an upgrade from 1.3.7r1 to 1.3.8, I have to reinstall all my hacks, plugins, etc ?? Thanks 1,000,000 ... Question
Die young, stay Pretty
 Quote

Status: offline

DTrumbower

Forum User
Moderator
Registered: 01/08/03
Posts: 507
I would copy the 1.3.7 db to another db. Install the 1.3.8 code and do an upgrade on the new 1.3.7 db. Most plugins should work fine on the upgrade. If you made any code changes, you will have to re add them. Hopefully most of them are in your lib-custom.php. If you don\'t upgrade to 1.3.8, you should at least upgrade to 1.3.7r2. This fixes two security holes.
 Quote

Status: offline

xspace

Forum User
Regular Poster
Registered: 03/04/03
Posts: 100
Quote by DTrumbower: I would copy the 1.3.7 db to another db.
You mean the GL files in mysql/data ?? Or a dump ?
Die young, stay Pretty
 Quote

Status: offline

DTrumbower

Forum User
Moderator
Registered: 01/08/03
Posts: 507
Sorry for not being clear, acutally I was a little vague it seems. Copy the whole system, db and files to another location. Install 1.3.8 files into this new location and run the install/upgrade process. Make you changes to this new version. Once you have everything working, move it to your main site.
 Quote

Status: offline

xspace

Forum User
Regular Poster
Registered: 03/04/03
Posts: 100
Thx bower .... Could I juz make it clear as : 1. Make a copy of the whole GL directory 2. Make a copy of the GL dbase @mysql/data 3. Upzip all 1.3.8 into duplicated directory, allow all files to overwrite the older one. 4. Make amendments to config.php and lib-common.php 5. Do installation, and select upgrade dbase, and point it to the original dbase 6. Make other necessary changes to lib-custom / other files which has been hacked. 7. Voila Is this roughly what I should perform .. I could actually try it out directly .. however due to the importance of articles, etc in my present GL .. I goto be 100% sure ... Thx for the time !
Die young, stay Pretty
 Quote

Status: offline

DTrumbower

Forum User
Moderator
Registered: 01/08/03
Posts: 507
That looks good if you are upgrade the main, but I though you wanted to copy everthing and work on the copied files and db. If you want to do the latter than you step 5 should point to the copied version. Now matter what you do, always make backups.
 Quote

All times are EDT. The time is now 10:44 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content