Welcome to Geeklog Thursday, August 22 2019 @ 11:02 pm EDT

Geeklog Forums

Plugin assistance


Status: offline

ronack

Forum User
Full Member
Registered: 27/05/03
Posts: 612
I voluntered to assist with a new plugin. My problem, it\'s my first one and I\'m not much of a php programmer, but I\'m not letting that stop me. You probably have seen the request for help with zClassifieds plugin, Yep that\'s the one I\'m working on. Anyway we are getting close, we just have some issues(bugs) that need worked out. I will struggle and try to figure it out but what I need is someone that can get me past brick walls that I can\'t seem to get past. For instance; 1. The Admin for the plugin isn\'t showing up in the Admins Only area. 2. Haven\'t gotten the main part to the User Function area either. 3. Security isn\'t working quite right. Root can do anything but no one else can anything. 4. Need to pull user information to Account Information. This needs to intagrate with UserSettings and will be a much more involved fix. Once these are fixed then we are very close to being done. So if you can assist with these issues drop me a line at ron@miplanet.net. Thanks Ron

Status: offline

Euan

Forum User
Full Member
Registered: 22/04/02
Posts: 292
The Admin for the plugin isn\'t showing up in the Admins Only area. Haven\'t gotten the main part to the User Function area either. * in functions.inc, if you are using the universal plugin kit, contains a lot of commented-out functions. These include the ones for adding links to the User block, menu bar, and admin block. Uncomment them and ..... voila.... Security isn\'t working quite right. Root can do anything but no one else can anything. * Have you really understood the way you create/apply features/usergroups in GL? I know this took me a while to get my head around... look closely at the code at the bottom of the functions.inc file for installing plugins and the tables used there. Make sure that when you uninstall you remove everything from the relevant tables too.
-- Heather Engineering -- No job too small

Status: offline

ronack

Forum User
Full Member
Registered: 27/05/03
Posts: 612
It was all in the functions.inc file. Seem most everything is working now. Now I just have some minor issues to work out. Thanks for everyones help.

All times are EDT. The time is now 11:02 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content