Welcome to Geeklog, Anonymous Tuesday, October 04 2022 @ 06:43 am EDT

Geeklog Forums

1064: You have an error in your SQL syntax near


Status: offline

Leita

Forum User
Chatty
Registered: 05/11/03
Posts: 37
Location:Colorado
Hi there - I am upgrading to 1.3.8 from 1.3.7 and am getting this error after I choose the option to \'Upgrade Database\' (1.3.7): 1064: You have an error in your SQL syntax near \'( id int(10) unsigned NOT NULL auto_increment, ipaddress varchar(15) NOT NUL\' at line 1 I opened the error log and it displays ***dummy entry*** I tried to upgrade again and am getting this error: 1060: Duplicate column name \'is_default\' Can someone help please? Thanks!
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Quote by Leita:1064: You have an error in your SQL syntax near \'( id int(10) unsigned NOT NULL auto_increment, ipaddress varchar(15) NOT NUL\' at line 1
That\'s the update script trying to create the new gl_speedlimit table. Did you forget to update lib-database.php?
Quote by Leita:I opened the error log and it displays ***dummy entry***
Translation: No errors yet (errors during the install are not recorded in error.log).
Quote by Leita:I tried to upgrade again and am getting this error: 1060: Duplicate column name \'is_default\'
Yep, you now have a database that is half-way updated. The safest thing to do would be to use your database backup, make sure you\'ve replaced all new files and try again. bye, Dirk
 Quote

Status: offline

Leita

Forum User
Chatty
Registered: 05/11/03
Posts: 37
Location:Colorado
Ahh yes, for some reason, not all the new files uploaded. I kept getting errors when I was uploading. I am certain all files are uploaded now - with the current date, but I am still getting the 1060 error.
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Quote by Leita:I am certain all files are uploaded now - with the current date, but I am still getting the 1060 error.
So did you restore your old database? As I said, your database is half-updated now, so it will choke on it when you try to run the update script. bye, Dirk
 Quote

Status: offline

Leita

Forum User
Chatty
Registered: 05/11/03
Posts: 37
Location:Colorado
Hi there ,) Yes, I restored my old database and reuploaded everything.
 Quote

All times are EDT. The time is now 06:43 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content