jhoke

Anonymous
I released a hack to integrate Amazon's Webservices XML feeds with GeekLog. This was done by utilizing the great amazonlite classs and tweaking them to work in a GL framework.

There is an example of this at slapd.net and the files are available at Squatty.Com (Thanks to Squatty for this great GL resource!).

The only thing left to really do for this is to

  1. test it
  2. work out GL Theme integration
If anyone can help with the theme integration, please email me at
john at hoke dot org

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Not sure what you mean by theme integration. For starters, you could simply wrap it in a block: $display .= COM_startBlock("Amazon Webservices"Wink; $display .= YourAmazonFunction(); $display .= COM_endBlock(); echo $display; bye, Dirk

jhoke

Anonymous
Dirk, Thanks for the info, I will try this... Smile -John

jhoke

Anonymous
Dirk, Thanks! that did the trick, you can see it now @ http://john.hoke.org/amazon/ if you sign up you can change the Theme and all works as planned Smile Thanks again!

Status: offline

squatty

Forum User
Full Member
Registered: 21/01/02
Posts: 269
You can also through in a: $display .= COM_siteFooter(true); To display the both right and left blocks.
In a world without walls and fences, who needs Windows and Gates?

jhoke

Anonymous
Squatty, Thanks for the tip, but I was talking about "fake" blocks that are created by the amazon script, not GL ...so I did as Dirk suggested, and BINGO she works Smile Demo: http://john.hoke.org/amazon

double_pumper

Anonymous
My hack has quit working for no known reason. I looked at all my logs and tried many different things, but to no avail.

Then I went to see if there was a new release and all I found was the one mentioned here.

Needless to say, I went to slapd.net and tried their search and found they have the same problem, so I'm assuming everyone will.

Is there an update to this block that I have not been able to find? If not, could someone have a look and maybe figure out why it's not working? I'm a VERY amateur programmer otherwise I would.

I am running 1.3.8-1sr3

Thanks.

Status: offline

squatty

Forum User
Full Member
Registered: 21/01/02
Posts: 269
Just a quick note to anyone using the Amazon/Geeklog integration....

XML requests which include an XSLT stylsheet should now be made to xml-na.amznxslt.com instead of to xml.amazon.com (US and JP locales only).

In other words, edit class.AmazonAPI.inc. and set the $amazonURL as follows:

var $amazonURL = 'xml-na.amznxslt.com';
In a world without walls and fences, who needs Windows and Gates?

Double_Pumper

Anonymous
Worked great!

Thanks a bunch.

Status: offline

jager

Forum User
Newbie
Registered: 13/11/03
Posts: 12
Quote by jhoke: Dirk,

Thanks! that did the trick, you can see it now @ http://john.hoke.org/amazon/

if you sign up you can change the Theme and all works as planned

Thanks again!


Hey guys, I checked out both the site listed above and slapd.net and neither of the amazon search screens work for me. They load up fine, but when I try to do a search it never generates any results...
Are you sure this is still working?

Status: offline

bcbrock

Forum User
Chatty
Registered: 04/02/03
Posts: 64
Quote by squatty: Just a quick note to anyone using the Amazon/Geeklog integration....

XML requests which include an XSLT stylsheet should now be made to xml-na.amznxslt.com instead of to xml.amazon.com (US and JP locales only).

In other words, edit class.AmazonAPI.inc. and set the $amazonURL as follows:

var $amazonURL = 'xml-na.amznxslt.com';


Squatty -

Thanks for this information - I was wondering why the searches kept coming up blank! :-)

Do you (or anyone else) happen to know if there is another change that needs to be made to access the wishlists??? Strange thing is, the script seems to be pulling information down from amazon's servers, but the contents of the wishlists are outdated. For instance, on my personal amazon wishlist, I've removed some items and added others. When I log into amazon's web site, my current wish list is displayed. However, when I use the wishlist script, it pulls up the items I had at around the same time they changed the server address, as you noted above. Odd.
~Brian