Welcome to Geeklog, Anonymous Thursday, April 18 2024 @ 08:23 pm EDT

Geeklog Forums

Has anybody seen this IE error?


Status: offline

jnordquist

Forum User
Full Member
Registered: 03/14/03
Posts: 129
Location:Kenosha
My site: http://KenoshaOnline.net (not complete, but getting there) comes up okay in Internet Exploder, but always with this error:

"Problems with this Web page might prevent it from being displayed properly... blah blah...

Line: 43
Char: 73
Error: Unterminated string constant
Code: 0
URL: http://kenoshaonline.net"

Has anyone seen one like this, and there is no reference to the actual file that Line 43, Char 73 is being called from... Thanks!


John Nordquist,
Applications Specialist, medical Technologies
 Quote

Anonymous

Anonymous
The problem is with your javascript. You're calling the function dynAnimation() in the body tag but don't define it properly. This function has no statements to execute and neither does the function clickSwapImg. You refer to a file named "animate.js", but the path to it is not listed correctly. You also have some formatting errors. There is no language attribute for the body tag. The script tag is missing a type attribute and fptype is not an attribute at all. The language attribute for the script tag was deprecated in HTML 4.01 so it should be dropped in favor of the type attribute.
 Quote

Anonymous

Anonymous
wow... that's a pretty comprehensive diagnosis! Thank you!!! Very much!
 Quote

Anonymous

Anonymous
You're welcome. I hate IE's non-descriptive error messages. It would be much more helpful if it just said "Fix your javascript." hehehe
 Quote

All times are EDT. The time is now 08:23 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content