Welcome to Geeklog, Anonymous Saturday, July 02 2022 @ 08:20 pm EDT

Geeklog Forums

Help, error loading gl


Howie

Anonymous
Can anyonw help me with this, I got this msg when I try loading the index.php Parse error: parse error, unexpected '<' in /home/werkz/public_html/voices/lib-common.php on line 2664 Thanks.
 Quote

Anonymous

Anonymous
If anybody can help with this installation as well. I've had no luck at all getting GL to run on my site. I'm hosted by Yahoo, running PHP 4.3 and mysql. I've gotten GL to work fine on my test server, but nothing from the Yahoo site. Any ideas? e-mail me..... melaas@netzero.com
 Quote

Anonymous

Anonymous
Parse errors are usually caused by not having matching quotes, brackets, parenthesis, etc or missing a ; or having a malformed command, or having extra characters floating around. Check out line 2664 and those around it to see if this is your problem. If you can't figure it out, then post a few lines above, including, and below that number.
 Quote

Anonymous

Anonymous
You don't give much info. What errors are you getting?
 Quote

Status: offline

dougm

Forum User
Newbie
Registered: 02/27/03
Posts: 13
no error messages are showing up. when I go to the index.php, the page just continually 'finds' itself, over and over again. Never displays anything, error messages or content.
 Quote

Status: offline

dougm

Forum User
Newbie
Registered: 02/27/03
Posts: 13
Try it yourself... http://www.pcmoch.org/index.php
 Quote

Status: offline

rawdata

Forum User
Full Member
Registered: 02/17/03
Posts: 236
Are you trying to install 1.3.7 or 1.3.7sr1? I thought Dirk fixed this problem in sr1.

If it's 1.3.7, then upgrade to 1.3.7sr1. If this is sr1, then go inside index.php and comment out this section of code:
Text Formatted Code

if (isset ($HTTP_SERVER_VARS['HTTP_HOST']) &&
        !empty ($HTTP_SERVER_VARS['HTTP_HOST'])) {
    preg_match ("///([^/]*)/", $_CONF['site_url'], $server);
    if (strcasecmp ($HTTP_SERVER_VARS['HTTP_HOST'], $server[1]) != 0) {
        // this may be a case of a www. vs. non-www. URL ...
        if (!empty ($QUERY_STRING)) {
            $query = '?' . $QUERY_STRING;
        } else {
            $query = '';
        }
        echo COM_refresh ($_CONF['site_url'] . '/index.php' . $query);
        exit;
    }
}
 
This should stop the constant cycling. The redirect was added because of a www versus non-www issue. In config.php, we enter the site's url either with or without the www. If someone enters the alternate way, they won't be recognized as being signed in. The redirect gets around this problem. If you can't use it though, you'll need to "fix" your cookies. I explained the problem in this post. Let me know if you need more detailed instructions.
 Quote

Anonymous

Anonymous
I did it! I am so so happy! *muaks!! hOWIE
 Quote

All times are EDT. The time is now 08:20 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content