Welcome to Geeklog, Anonymous Monday, March 04 2024 @ 10:46 pm EST

Geeklog Forums

new installation…


Status: offline

efischer

Forum User
Newbie
Registered: 12/23/02
Posts: 11
Hello again, I've made a fresh install of the updated GL. It's on a remote server, the IP gives me access to only one directory called web, so I had to install the non-public files in this directory too, I've made a seperate directory inside web for this.
How (un)safe could this be?

Installation went very well, but on top of each page I get the following:

Warning: fopen("/home/.sites/106/site15/web/geeklog/logs/error.log","a") - Permission denied in /home/.sites/106/site15/web/lib-common.php on line 1440

I did a chmod 775 on lib-common.php, but that didn't change it.
Exept for this everything seems to work fine.

thanks,

Eric
 Quote

Anonymous

Anonymous
It's late and I'm not an expert, but if I'm reading it right, I think it's not trying to open lib-common, it's trying to open the error.log. I received the same message (if I recall correctly) when I first installed GeekLog. Did you chmod the error.log (per the installation instrux) to 775? If not, try that. If you did, try chmod to 777 and see if that fixes it. (I don't remember if I had to also grant those permissions for the log directory itself; I know it's in the documentation...)
 Quote

Status: offline

vinny

Site Admin
Admin
Registered: 06/24/02
Posts: 352
Location:Colorado, USA
While not as secure as having the geeklog core files outside your web directory, you can prevent people from viewing them by creating a .htaccess file in the geeklog directory and have it include the following two lines: Order deny, allow Deny from all The above comment is correct as far as the error code you are getting. You must give write access to the error.log file all users so the web server can write to it.
 Quote

coakedhornet

Anonymous
Hello: I'm installing a new application and I'm running out of Ideas what to do: I have all the paths correct I have changed the required dir and files to 777 I have dowloaded everything with FTP and untar'd on the system I have modified config.php and lib-common.php and I'm still getting the following error: Parse error: parse error, unexpected T_CONSTANT_ENCAPSED_STRING in /home/virtual/site203/fst/var/www/html/geeklog/public_html/lib-common.php on line 3815 LBLBLBLBLBLB Testing your Geeklog installation ... LB Testing logs directory ... LBCould not open error.log and access.log for writing. Please check that you have set the logs directory and the files error.log and access.log in that directory to chmod 775.LB Warning: stat failed for (errno=2 - No such file or directory) in /home/virtual/site203/fst/var/www/html/geeklog/public_html/admin/install/check.php on line 74 Warning: stat failed for error.log (errno=2 - No such file or directory) in /home/virtual/site203/fst/var/www/html/geeklog/public_html/admin/install/check.php on line 75 Warning: stat failed for access.log (errno=2 - No such file or directory) in /home/virtual/site203/fst/var/www/html/geeklog/public_html/admin/install/check.php on line 76 LB Current permissions for logs: 0 LB Current permissions for error.log: 0 LB Current permissions for access.log: 0 LB LB Testing backend directory /backend/ ... LB Export of Geeklog headlines is switched off - backend directory not tested. LB User photos are disabled - userphotos directory not tested.LB Images in articles are disabled - articles directory not tested.LB Results: 1 of 4 tests performed: 0 successful, 1 failed. LB Test failed! Warning! Your Geeklog site is not set up properly. Please fix the errors listed above! LBLB Please help
 Quote

All times are EST. The time is now 10:46 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content