Welcome to Geeklog, Anonymous Wednesday, February 01 2023 @ 06:21 pm EST

Geeklog Forums

Parse error when selecting Comment Preferences


Status: offline

rv8

Forum User
Regular Poster
Registered: 10/10/02
Posts: 105
Location:Ottawa, Canada

I'm trying out functions on my new GL site, looking for any errors that users may run into.

If I am logged in, and select Comment Preferences, I get the following error:

Parse error: parse error in /home/khorton/config.php on line 297 is temporarily down. Please check back soon

Line 297 is:

$_CONF['comment_code'] = 0; // 0 = comments enabled, -1 = disabled

I checked the error.log, but there were no new errors logged. I've rooted around, but I can't find any reference to comment_code in any obvious place.

Does anyone have any idea on what I need to do?

Thanks,

Kevin


Kevin Horton
 Quote

Status: offline

rv8

Forum User
Regular Poster
Registered: 10/10/02
Posts: 105
Location:Ottawa, Canada
OK - I found the problem. I had edited the config.php a while before to change the default comment mode. Somehow pico caused the end of the comment on that line to wrap to a new line, which caused the parse error. I've had pico do that on me a couple of times. Reading the manual, it looks like I should be using the -w option to disable word wrap. I don't want to learn emacs or vi, so I'll stick it out with pico. Kevin
Kevin Horton
 Quote

All times are EST. The time is now 06:21 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content