Welcome to Geeklog, Anonymous Sunday, July 21 2024 @ 07:21 am EDT

Geeklog Forums

Staticpages-Frontpage


jhoke

Anonymous
i have a wierd problem. I am running gL 1.3.6 Static Pages 1.2 I create a static page called Frontpage to post ontop of the homepage, and if I view it as a regular staticpage, the urls in the href tags are correct... When it if viewed as a "Frontpage' piece, all of the urls are prepened by my full URL to the home page of my site... obviously this is not a "good thing" Anyone have this issue, or know how to fix it? -John
 Quote

jhoke

Anonymous
I have put up an image showing how it looks when setup as a "Frontpage" piece... if you look in the status bar in the img you will see what I mean ...

Picture
-John

 Quote

jhoke

Anonymous
After searching around, there seems to be a stripslashes problem as if I remove the slashes from what is stored in mysql, all is well ... Any ideas where to look for the problem? -john
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany

Now that you mention it ... There is indeed a stripslashes() call missing when using a static page as the frontpage.

A fixed version of index.php is available from CVS.

bye, Dirk

 Quote

All times are EDT. The time is now 07:21 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content