Welcome to Geeklog, Anonymous Tuesday, July 16 2024 @ 08:14 am EDT

Geeklog Forums

submit problem


Status: offline

Euan

Forum User
Full Member
Registered: 04/22/02
Posts: 292
Hi there. I would appreciate any feedback on this problem: Only when display language is set to "Japanese", users cannot submit stories. Admin are fine, but anonymous and normal users cannot submit. When they click preview, the usual "enter title/content/topic" error message comes up, there is no preview pane and their content disappears. There are no problems with other languages (eg German, English). Where should I start looking for the problem? Geeklog 1.3.5sr2 (patched from sr1 which I patched from 1.3.5) Apache 1.3.26 Linux fox 2.4.18-5smp #1 Php 4.2.2 mod_gzip/1.3.19.1a MySql 3.23.39 Cheers, Euan.
-- Heather Engineering
-- No job too small
 Quote

Status: offline

Tony

Site Admin
Admin
Registered: 12/17/01
Posts: 405
Location:Urbandale, Iowa
I'm guessing there is a case statement in submit.php that receives $mode from the url string and does a switch on it (see the bottom of the page). My hunch is the switch is language dependent (yes, I know that is bad) so you probably need to verify what it is checking against in your language file.
The reason people blame things on previous generations is that there's only one other choice.
 Quote

Anonymous

Anonymous
Thanks. In the last part of submit.php (after // MAIN), there is a switch on $type, the last part of which is for default. If I use the link g-comm.net/submit.php or g-comm.net/submit?type=story, in both cases I get just the blank form. I was wrong earlier when I said that the error message was appearing to say fill in the fields: I am just getting the blank form again. I am presuming that the last $display is being shown, and that there is just no data being entered into the strings when attempting to enter preview mode. Odd. Language fields all seem okay (I had a missing $LANG12[53] but I seem to remember this being in CVS and it desn't help). I'll probably just try overwriting the PHP files again as there mst be an error in there somewhere. Cheers, Euan.
 Quote

Status: offline

Euan

Forum User
Full Member
Registered: 04/22/02
Posts: 292
That didn't work either. Still the same problem. Could this be something to do with the server/php and the language setting? This is a real problem as over 50% of my users are Japanese... Next step is reinstall from zero... aargh. Euan.
-- Heather Engineering
-- No job too small
 Quote

Status: offline

Euan

Forum User
Full Member
Registered: 04/22/02
Posts: 292
Okay, found it. In submit.php function submitstory() at about line 307, there is: if ($HTTP_POST_VARS['mode'] == $LANG12[32]) { $A = $HTTP_POST_VARS; If I change $LANG12[32] in language/japanese.php from what it should be to "Preview" then everything works perfectly. In fact, I can change it to anything in English or Japanese - so it's not a hard-coded text problem. I found once that a particular Japanese character caused problems when in phpblocks. That same Japanese character is in the Japanese for "preview" - I wonder if this character is being interpreted wrongly somewhere in GL? That would make this a bug... Cheers, Euan.
-- Heather Engineering
-- No job too small
 Quote

All times are EDT. The time is now 08:14 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content