Welcome to Geeklog, Anonymous Monday, April 15 2024 @ 07:38 am EDT

Geeklog Forums

Browsing my web localy


Status: offline

dodonpachi

Forum User
Junior
Registered: 05/13/02
Posts: 23
Location:Barcelona
I can't browse my web localy. I must use a proxy to access my web. Because my router sends me its configuration page if I use my IP as adress. My site_url is http://212.170.15.68/public_html (yes, I have 2 public_html dirs nested) and my local host is localhost
if I use http://localhost/public_html I access my page but most of the links are of the 212.170.... type.
Is there any way to browse localy
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Maybe I didn't understand the problem, but why do you not simply use $_CONF['site_url'] = 'http://localhost/public_html'; bye, Dirk
 Quote

Anonymous

Anonymous
I think you did.
But if I use localhost the links that use appear with localhost, even in other computers.
In brief, in that case I can view my page but THE OTHERS can't view my page.
 Quote

Status: offline

dodonpachi

Forum User
Junior
Registered: 05/13/02
Posts: 23
Location:Barcelona
In fact, the guy that is helping me in this, say that the menu pictures (polls, calendar, etc..) of the yahoo theme do not appear. If he checks the URL of the pics it says: http://localhost/public_html/imagesorwhatever
(of course, because site_URL is http://localhost/public_html )

Another question that I have related to this: Is there any way to link a history (in another history for example) relatively ?? (not with all URL)

And another matter: If you plan to release a manual about geeklog (installation, FAQ, configuration, etc.) I'm interested in translating it to spanish
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
So if I understand you correctly: When you use the IP address, it works for others but not for you. But if you use localhost, it works for you but not the others? This, I'm afraid, is a problem with your local setup. You need to find another way to address your web server that works for both your visitors and yourself. Maybe using a service such as dyndns.org or dns2go.com would help? bye, Dirk
 Quote

Status: offline

vinny

Site Admin
Admin
Registered: 06/24/02
Posts: 352
Location:Colorado, USA
Needing to do something similar, here are the steps that I took to solve this dilemma: 1. sign up for a free 3rd lvl dns name from someplace like www.dyndns.com. 2. set this dns as the url for site $_CONF['site_url'] = 'http://xxx.xxx.xxx/public_html'; 3. edit your /etc/hosts of C:\WINNT\system\drivers\etc\hosts and add the line: 127.0.0.1 xxx.xxx.xxx Note: xxx.xxx.xxx is the dns name you signed up for in step 1 Note2: your ip address will still work for people outside your site to get to you site, but all links will be by the dns name. Note3: some changes might need to be made to your apache.conf file depending on your current apache setup. -vinny
 Quote

Status: offline

xLekOx

Forum User
Newbie
Registered: 08/29/03
Posts: 1
Hi dodonpachi, Hi all Another better and easy solution, open config.php in line aprox 82, in site settings where $_CONF[\'site_url\'] = \'http://212.170.15.68/public_html\'; Change this for that: $ip = getenv(\"REMOTE_ADDR\"); if ($ip=\'127.0.0.1\') {$_CONF[\'site_url\'] = \'http://localhost\';} else $_CONF[\'site_url\'] = \'http://212.170.15.68/public_html \'; Everything must work ok Wink Razz PD: I\'m from Spain
 Quote

All times are EDT. The time is now 07:38 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content