Damjan

Anonymous
Hello, I have problem with my geeklog v2.1.1 (php5.6) page - http://www.banki-bez-gwiazdki.pl

I am trying to log in to the admin panel to add a new entry, but when I enter login, password and login, nothing happens, I have the impression that the page is trying to load and then returns to the login panel, and I'm still not logged in and I can not nothing to add.

I did everything that was given in the FAQ, please help me with this I can not log in for a year, before there were no problems with it, suddenly the login stopped and the site is useless.


Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/05
Posts: 1381
I visited the site and tried a bogus name and password and the login form was returned so I don't think it is that.

I think you have logged in but cannot view the Admin control panel.


What are the latest errors in the error.log file?


When you attempt to log in (and it returns to a blank page) what happens when you then visit the page

http://www.banki-bez-gwiazdki.pl/admin/


One of the Geeklog Core Developers.

Damjan

Anonymous
when I click on the link from / admin the login page opens with a message in red: "Any attempts to enter the sphere.
Access to the control panel allows access to the administration panel. "However, I still can not log in or access the admin panel, try to see if something is in error.log, however, I need to enter the company pc for data to ftp. However, as I checked today logos are a minute to log in. Last entries were from October last year.

Damjan

Anonymous
last entries in error.log - as I wrote in October 2018, so I have no idea what to do to log in

Sat Oct 20 17:13:05 2018 - 94.103.9.30 - Someone tried to submit an item to the story%20ORDER%20BY%201%23-plugin, which cannot be found.

Sat Oct 20 17:13:05 2018 - 94.103.9.30 - Someone tried to submit an item to the story%20UNION%20ALL%20SELECT%20NULL%23-plugin, which cannot be found.

Sat Oct 20 17:13:05 2018 - 94.103.9.30 - Someone tried to submit an item to the story%20UNION%20ALL%20SELECT%20NULL%2CNULL%23-plugin, which cannot be found.

Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/05
Posts: 1381
Can you login with another user? (just to see if it works)

Have you tried repairing the database?

It's hard to diagnose the problem without more info.

You could send me an email (link from my profile) with the login details and I can try it out myself. Most likely I would need FTP access and PHPMyAdmin access as well to fix what ever the issue is.
One of the Geeklog Core Developers.

Damjan

Anonymous
I do not know how to repair the database, I will try to write an email soon.

Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/05
Posts: 1381
FYI to others with this issue. The problem is now fixed.

When I looked at the code and ran some tests for some reason the form variables for the login form was empty. The post variables were not being passed. After some research I found this post which explained the issue:

https://serverfault.com/questions/127674/mysteriously-empty-post-array

It appears that a redirect was added at some point to the web server to redirect the domain from

banki-bez-gwiazdki.pl/

to

www.banki-bez-gwiazdki.pl/

This combined with the incorrect Geeklog configuration values for site_url and site_admin_url which was missing the "www." part in the domain caused the issue.

Remember when changing the domain name at all you should run the Geeklog install script again (for the version of Geeklog you have installed) and then select the Migrate option. This will update all the configuration variables needed.

One of the Geeklog Core Developers.