Status: offline

jordydme

Forum User
Full Member
Registered: 03/11/05
Posts: 135
Hi,

I have an old outdated site that I have no intention of updating...too many customizations. Lately I have been getting hit with spam in the form of anonymous replies to blog posts. Does anyone know how to to set the permissions so that all comments and replies need to have admin approval?

http://highschoolforthehumanities.org/geeklog/

I know it's an old version and you will probably tell me to get lost but I thought it might be any easy fix. Is it a setting in the config?

Version
1.3.11sr2,

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
That version didn't have comment moderation yet - that was only added in Geeklog 1.6.0.

You could try finding an older version of the CAPTCHA plugin that works with 1.3.11.

bye, Dirk

Status: offline

::Ben

Forum User
Full Member
Registered: 14/01/05
Posts: 1569
To only allow registered users to send comment
$_CONF['commentsloginrequired'] = 1;


Ben
I'm available to customise your themes or plugins for your Geeklog CMS

Status: offline

::Ben

Forum User
Full Member
Registered: 14/01/05
Posts: 1569
was working for Geeklog v1.3.11sr2

Ben
I'm available to customise your themes or plugins for your Geeklog CMS

Status: offline

jordydme

Forum User
Full Member
Registered: 03/11/05
Posts: 135
Quote by: Dirk

That version didn't have comment moderation yet - that was only added in Geeklog 1.6.0.

You could try finding an older version of the CAPTCHA plugin that works with 1.3.11.

bye, Dirk



Thanks, any way to disable comments?

Status: offline

jordydme

Forum User
Full Member
Registered: 03/11/05
Posts: 135
Quote by: ::Ben

To only allow registered users to send comment

$_CONF['commentsloginrequired'] = 1;


Ben



Thanks Ben, where would I add that?
I am also open to disabling comments all together if you have an easy solution for that.

Status: offline

jordydme

Forum User
Full Member
Registered: 03/11/05
Posts: 135
Quote by: ::Ben

To only allow registered users to send comment

$_CONF['commentsloginrequired'] = 1;


Ben



thanks, I found that piece of code in the config and it was already set as you suggested "1". So they are registered users. I will try the captcha but might be interested in disabling comments all together, if possible.

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Quote by: jordydme

I will try the captcha but might be interested in disabling comments all together, if possible.


An SQL request like
PHP Formatted Code
UPDATE gl_stories SET commentcode = -1;
should do the trick. This would set all your stories to "comments disabled".

bye, Dirk

Status: offline

::Ben

Forum User
Full Member
Registered: 14/01/05
Posts: 1569
So they are registered users.


In your first post you told

I have been getting hit with spam in the form of anonymous replies to blog posts


Question

Ben
I'm available to customise your themes or plugins for your Geeklog CMS

Status: offline

1000ideen

Forum User
Full Member
Registered: 04/08/03
Posts: 1294
I`d also recommend the plugin badbehavior or an update of it.