Welcome to Geeklog Tuesday, October 17 2017 @ 07:24 am EDT


Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/2002
Posts: 13073
Location:Stuttgart, Germany
Bad Behavior 1.1.3 is now available for download.

bye, Dirk

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/2002
Posts: 13073
Location:Stuttgart, Germany
Bad Behavior 1.1.4 is out, as is the Geeklog plugin of the same name.

This release also addresses two bugs specific to the Geeklog plugin:
  1. Fresh installs often ended with an SQL error.
  2. The log only showed the first 50 entries (the "Google paging" at the end of the page was missing).

bye, Dirk

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/2002
Posts: 13073
Location:Stuttgart, Germany
Michael has released Release Candidate 1 of Bad Behavior 1.2. If you want to try it out, simply download it and copy the files over the ones that ship with version 1.1.4 of the Geeklog plugin (make sure to keep the bad-behavior-geeklog.php file).

I'll release a proper update when 1.2 goes final.

bye, Dirk

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/2002
Posts: 13073
Location:Stuttgart, Germany
Michael Hampton has released Bad Behavior 1.2. See the announcement on his site for the details.

On the Geeklog side, I had to remove the "self test" feature, as Bad Behavior now keeps track of IP addresses that misbehaved. So after the self test, you would be blocked from your own site ... I'll try to come up with a solution in a future release.

Also new is the ability for members of the Bad Behavior Admin group to search through the Bad Behavior logs.

The Geeklog plugin is available for download from here, as usual.

bye, Dirk

Status: offline

ScurvyDawg

Forum User
Full Member
Registered: 06/11/2002
Posts: 523


Dirk you ROCK!!!

Benta

Anonymous
excited
Quote by Dirk: Michael Hampton has released Bad Behavior 1.2. See the announcement on his site for the details.

On the Geeklog side, I had to remove the "self test" feature, as Bad Behavior now keeps track of IP addresses that misbehaved. So after the self test, you would be blocked from your own site ... I'll try to come up with a solution in a future release.

Also new is the ability for members of the Bad Behavior Admin group to search through the Bad Behavior logs.

The Geeklog plugin is available for download from here, as usual.

bye, Dirk


A new one already? Sweet.

Anything one should think about when upgrading from 114? Do we need to uninstall the 114 and reinstall 1.2?

Thanks!

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/2002
Posts: 13073
Location:Stuttgart, Germany
Quote by Benta: Anything one should think about when upgrading from 114? Do we need to uninstall the 114 and reinstall 1.2?

You could try reading the included installation instructions ...

bye, Dirk

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/2002
Posts: 13073
Location:Stuttgart, Germany
If you experienced an SQL error in fresh installs, please download the plugin again.

The change is in public_html/bad-behavior-database.php and does not affect updates from earlier versions.

bye, Dirk

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/2002
Posts: 13073
Location:Stuttgart, Germany
Bad Behavior 1.2.1 is out, fixing a problem with the whitelist.

The Geeklog plugin is avaliable here, as usual.

bye, Dirk

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/2002
Posts: 13073
Location:Stuttgart, Germany
Bad Behavior 1.2.2 is out, and the Geeklog plugin of the same name is available here.

Michael Hampton has replaced BB's automatic 48 hour block with a more dynamic approach. Sorry again to the few people who ran into this on geeklog.net ...

On the Geeklog side, the plugin now also lists the most common misbehaviors in the site's stats section (visible only to Bad Behavior Admins, of course).

Also new is a search option from the request details page. Often, you will find a note there saying "I know you and I don't like you, dirty spammer" which means that this request came from a repeat offender. But you didn't know why it was blocked in the first place. Now you can use the "search" option next to the IP address to get a list of previous entries for that IP address, the first of which will also list why that address was blocked.

And as a reminder: Bad Behavior links IP addresses to the Whois info from Tom Willet's NetTools, if those are installed and enabled in config.php ($_CONF['ip_lookup']). This makes it easier to find out that that blocked GoogleBot was indeed fake, since it came from Russia ...

bye, Dirk

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/2002
Posts: 13073
Location:Stuttgart, Germany
I completely missed Michael's announcement of Bad Behavior 1.2.3 a week ago. The Geeklog plugin has now been updated to sync with that version.

I'd also like to point out Michael's helpful article What to do when Bad Behavior blocks you (or your friends) in case you run into problems with this plugin.

Furthermore, there's an experimental Bad Behavior module for Spam-X. So when Spam-X encounters a spam post, it reports the spammer's IP address to Bad Behavior which then blocks all further attempts. This may help in cases where you get a lot of spam from the same IP address.

bye, Dirk

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/2002
Posts: 13073
Location:Stuttgart, Germany
Michael Hampton has released Bad Behavior 1.2.4. The updated Geeklog plugin is available from the usual place.

On the Geeklog side, this version fixes a minor bug in the search function: When the query string was empty (e.g. when you where searching by author), the plugin returned all its entries. Empty search queries are now ignored unless you explicitly search for entries of type "Bad Behavior".

bye, Dirk

Status: offline

kirkmc

Forum User
Newbie
Registered: 28/09/2004
Posts: 12
The doc says this works with GL 1.3.x, but I'm running 1.3.9 and I get a message, when trying to install, that I need a later version of GL.

I know, I should probably upgrade, but don't have the time, as this seems like a daunting procedure. In the mean time, you should probably correct the doc for the plugin.

Best,

Kirk
Read my blog: Kirkville -- http://www.mcelhearn.com Musings, Opinion and Miscellanea, on Macs, iPods and more

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/2002
Posts: 13073
Location:Stuttgart, Germany
Okay, it's not too obvious, but the "1.3.10" that is part of the archive name is the minimum Geeklog version required for this plugin.

bye, Dirk

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/2002
Posts: 13073
Location:Stuttgart, Germany
I've just uploaded a small update to the Bad Behavior plugin for Geeklog. This update does not change anything in the actual blocking functionality but only in the Geeklog backend:

Changes

Bad Behavior 1.2.4-1 uses the exact same version of the WordPress plugin as
1.2.4, i.e. there were no changes as far as blocking spam bots and the like
are concerned. All the changes happened in the Geeklog backend.

- Now requires at least Geeklog 1.4.0
- Added an option to unblock an IP address (from the detail view).
- The overview of recently blocked requests now lists the reason instead of the
referrer. This should make it easier and more obvious to figure out why a
request was blocked (without having to click through to the details view).
- Fixed inconsistency in the search results page: Clicking on the IP address
will now actually do an IP lookup (if $_CONF['ip_lookup'] is enabled). To
see the details of a blocked request, you will now have to click on the date.
- Made the statistics blend in with the 1.4 design.
- Added instructions for the included Spam-X module.


I am fully aware that there's already a version 2 of Bad Behavior. That is, however, a complete rewrite of the original WordPress plugin and I haven't had the time to look into it.

bye, Dirk

Jon Almada

Anonymous
Got this error on installing the plugin to my 1.4.0sr5-1 site...

Plugin Compatibility Check Failed

This plugin requires a newer version of Geeklog. Either upgrade your copy of Geeklog or get a newer version of the plugin.

Any thoughts? I thought that 1.4.x sites ran with the new plugin...

Jon

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/2002
Posts: 13073
Location:Stuttgart, Germany
The install script checks for the existence of function SEC_getGroupDropdown - which is only available as of Geeklog 1.4.1. Not sure why it does that, though, since Bad Behavior doesn't need that function.

You can remove that check from the plugin's install.php for now. I'll update the tarball later today. Sorry about that.

bye, Dirk

Jon Almada

Anonymous
Dirk - I did as you said and it worked great! Many thanks! This plugin is really great and it already caught 47 headers before I ran the install of the plugin ;>Wink

Take that bots!

Jon

All times are EDT. The time is now 07:24 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content