Welcome to Geeklog Wednesday, April 08 2020 @ 08:56 am EDT

Geeklog Forums

Geeklog 1.5.1 and advanced editor

Page navigation


guest

Anonymous
Quote by: cordiste

Did you try in Config - Users and submission - User submission - Default post mode - HTML Formatted ?


Thanks, it worked! However, why is it called HTML Formatted if it doesn't use the HTML mode (which is a mode of its own)? Also, how come the root admin must use the advanced editor by default regardless of that option?
 Quote

Status: offline

::Ben

Forum User
Full Member
Registered: 14/01/05
Posts: 1569
Location:la rochelle, France
Yes advanced editor is magic Smile

You write Hello world in plain text and the advanced editor with the help of javascript change it to <p>Hello world</p>. You can view the source code hitting the source bouton or switch to html mode.

So no confusion, it is html formatted whitch is store in the db when you enable advenced editor and publish content in this mode.

::Ben
I'm available to customise your themes or plugins for your Geeklog CMS
 Quote

Guest

Anonymous
Regardless, Geeklog has a mode called HTML mode on its own. In live edit you get to choose between text mode, HTML mode and advanced editor. Why don't you get the same choice in the config?

And again, how come the root admin always gets the advanced editor regardless of the aforementioned choice?
 Quote

Status: offline

::Ben

Forum User
Full Member
Registered: 14/01/05
Posts: 1569
Location:la rochelle, France
Why don't you get the same choice in the config?

I think it is historical. Advanced editor is like a "layer" came to geeklog in 2006, it's why his setting is separate from old plaintext/html setting. Maybe it would be nice if the Default Post Mode setting is just before the Advanced Editor setting in the config aera. Anyway, it's a nice feature to have separate settings because you can disable FCKEditor and set another like Tinymce for exemple.

And again, how come the root admin always gets the advanced editor regardless of the aforementioned choice?

If you enable avanced editor, his setting is master (Sorry I don't know the right word in english).

::Ben


I'm available to customise your themes or plugins for your Geeklog CMS
 Quote

Status: offline

::Ben

Forum User
Full Member
Registered: 14/01/05
Posts: 1569
Location:la rochelle, France
To allow image in story with FCKEditor:

In the config set Skip HTML Filter for Root to true or allow the <img> tag for story admins as Dirk suggested here

::Ben


I'm available to customise your themes or plugins for your Geeklog CMS
 Quote

Page navigation

All times are EDT. The time is now 08:56 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content